OF2, High Sierra, ios12 and Server webdav success stories?

Hi -

Am I the last OF2 Mac user on local sync (until last evening, Sierra + MacOS Server Webdav)?

I’m hoping there’s someone out there that can chime in on local sync success for High Sierra.

I upgraded from Sierra to High Sierra last night w/o problem. Stumbled through the OSX Server upgrade, got WebDav running and was able to sync my OF2 Mac client to the server.

When I tried to sync OF2 for iOS to an iOS12 iPhone, I received an error.

"The ____ server returned "bad gateway (502) in response to a request to “PROPFIND /servdav/omnifocus.ofocus”.

When I loaded the iOS sync URL into iOS safari, I got an unsafe msg–warning me that my Server self-signed certificate could be a problem. As a result, I emailed my Mac Server cert and imported it into my iPhone.

Sadly, sync to iOS device is still not working.

  1. Is there a way forward using HighSierra + OSX Server for webdav sync on iOS devices?

  2. Do I need to roll back my Mac to Sierra in order keep local sync?

  3. While I’d prefer Apple-sourced software, does anyone have good stories of consistent success with WebDavNav on HighSierra?

Thanks much.



I went through something similar when I updated my 2012 Mini from Sierra to High Sierra. I had been running macOS Server on it for its webdav support as well as the time machine server. I had been using the webdav server for OmniFocus and OmniPresence syncing which was working well. What I found on booting into High Sierra was that webdav was completely broken so I restored the Mini back to Sierra using a Time Machine backup. I then tried the WebDAVNav app on Sierra to see if I could get that working for my syncing purposes and it seemed to work on Sierra but when I updated the Mini to High Sierra again, I found the syncing was unreliable in that OF would sync once and after that sync would not work. So I went back to Sierra and I’m now working on getting the apache 2.4 httpd (from homebrew, very easy install) configured for WebDAV and hoping that will continue to work reliably when I update to High Sierra. Given Apple doesn’t seem to care about Server and has done a terrible job maintaining functionality across updates I’m going to use as much open source software as I can to maintain my Mini’s WebDAV service.

Anyway, give WebDAVNav a shot – it’s easy to configure and may do the trick.

1 Like

Thanks wfiveash.

I gave WebDAVnav a shot and, after working out some sync kinks with a couple of super-helpful OF tech support folks, iOS device sync is working.

Here’s hoping that whatever unreliablity issue you’d previously run into has been fixed… but if anything does crop up for me, I will note it in this thread.


I’m still running Sierra and OS Server woth WebDAV. Planning toupgrade to High Sierra soon. Originally I tried WebDAVnav and never could get it running so went back to the Apple stuff. However, the error you got is one I still occasionally get on my Sierra system. My fix is one of these and it’s never failed so far, fingers crossed.

The issue is related to the self signed certificate for secure access.

Fix is
first delete the certificate in server.app
Create a new one and self sign it.

Go into OF and set up no sync
go into OF set up sync with WebDAV
When you get the untrusted certificate message select show certificate
in the drop down area click the arrow to the left of the trust in the when using this certificate are select the drop down for always trust
click continue

DO NOT use the Always trust checkbox at the top and DO NOT just trust once.

Alternative fix that sometimes works

Go into server
select DAV folder
shut off all sharing
shut down server
restart server
restart OF and DEVONThink

This may not help, but - I run Server on a Mac mini and I’ve left it running Sierra because the later versions of Server have so much deprecated. It’s been very reliable for me, including WebDAV sync with OF (and other apps)

I’ve been using WebDavNavServer for years (and continue to do so on Mojave and OF3) with no issue. As long as I’m on a real wifi network it works great. Sometimes on mobile hotspots one of my devices won’t sync until I kill OF, toggle airplane mode, wait for bonjour to reestablish the machine.local discovery, and then relaunch OF.

OSX Server isn’t long for the world I think - it’s been a half-effort at best the past few releases. WebDavNavServer has been rock solid.

Thanks for all the input. One week and an OF3 for Mac upgrade and webdavnav sync still working…

1 Like

Very cool! I just upgraded to OF 3 on both iOS and OSX, and still works great…thanks to Omni for preserving this critical option!

Thanks @snakeears for raising the topic. Have you ever had the error

"Unable to read document. No document exists at “/name-of-my-sync-folder/OmniFocus.ofocus/ – https://name-of-my-mac.local:8080/name-of-my-sync-folder/OmniFocus.ofocus$encrypted/” ?

with your WebDAVNav installation?

So far I couldn’t get around it with OF3.0.1 and WebDAVNav2.6.4 on my Mac (High sierra 10.13.6) and iPhone on iOS12.
Creating the missing file as a copy of the OF3 database also didn’t do the trick, also not renaming its file extension to .ofocus$encrypted

My advice is to backup the OmniFocus.ofocus directory (using Finder, use the Compress… option) and restore that on the updated Mac. Beyond that, make sure that the share path for webdav is /name-of-my-sync-folder (don’t include the OmniFocus.ofocus dir) and check the file permissions of the directories and files under your sync folder including OmniFocus.ofocus to make sure that they are read/write/searchable by either the user ID or group ID that the webdav daemon is running as.

1 Like

Hi Ohrar:

I haven’t seen this error message and do consider myself lucky that I didn’t run into any issues moving over to WebDavNav.

Hopefully wfiveash’s suggestion helps.

1 Like

Thanks! Do you mean by this the “WebDAVNav Server” in the activity monitor? Then all your requirements are met except the first, which I probably don’t need, because the OF2 data were imported on installation of OF3 automatically. But no success so far…

Did your approach via

work and do you use it now?

Sounds like you are using the WebDAVNav server from the Apple store so yes, you should look at that daemon to see what UID it’s running as (it’s probably the same as the UID that starts WebDAVNav). I can tell you that configuring the apache2 httpd from scratch is far from easy, which is why I haven’t finished yet, so I’d say try using WebDAVNav for now and see if you can find any log files it outputs to help with debugging your setup.

1 Like