OmniFocus 1 on El Capitan?


#1

I would be really curious to know if OmniFocus 1 still works on El Capitan. The less software I have to replace, the more time I can spend on other things :) Has anyone tried it yet?


#2

It appears to work on a very cursory test. Can’t confirm about more thorough usage.


#3

Thanks for testing! Sounds promising :)


#4

I find OF 1 still works for the most part on El Capitan public release with a couple minor UI glitches where the window will flash to black in certain circumstances.

Quick Entry is also broken. It can be temporarily fixed by reseting the quick entry shortcut combo in OF preferences. However, it will stop working the next time OF is restarted.


#5

Thanks for sharing! Hmm, Quick Entry is a must-have. I guess I’m stuck on Yosemite then, until Apple forces me to update via Xcode.


#6

I’ve tried out OmniFocus 2.3 in the meantime, but I’m not impressed, so I installed OF 1 in my El Capitan VM instead.

Quick Entry seems to work just fine, even after quitting OF and restarting it. I was using cmd+ctrl+alt+Q as the shortcut for testing. Do you think it might have to do with the specific shortcut that you’ve used? Was is the default keyboard shortcut (ctrl+cmd+space)?


#7

Just adding so I can track the thread.

I still have my fingers crossed that (someday) OF2 will be feature complete when compared to OF1. Until then, I am on OF1 all the way.


#8

I use ctrl+opt+space, and it needs a reset every time that OF 1 starts under El Capitan. Not a big deal, since I don’t quit OF very often.


#9

I have the same issue since I upgraded to El Capitan and have been using OF v1 with the ctrl+opt+space quick entry shortcut. I just changed that in OF prefs to shift+ctrl+i (for inbox) and restarted OF and that shortcut still works.


#10

I’ve started using cmd+alt+i (thanks for the inspiration), works perfectly, thanks! Other than that, and some flashing when you resize the window, everything seems to work fine ❤️