Omnifocus 3 IAP [SKErrorDomain Code=0 is an App Store problem, not an OmniFocus problem]

Trying to buy IAP upgrade from OF 2 to OF 3 for macOS and I get an error (new toy released today!):

SKErrorDomain Code=0

in the app and can’t buy the upgrade (UK Mac App Store). I googled and found this discussion on apple dev forum:

Can someone help me give Omnigroup my money?

I’m not sure if anyone here will be able to help you definitively. If you’re still having troubles upgrading, I would email to see if they can help. Just keep in mind they’re a bit overwhelmed right now.

Fortunately you’ve got another two weeks before you must hand over that money. 🙂

Contacted Omnifocus Support and received this reply. Have not found a solution yet.

Thanks for your email and interest in our software! Sorry for the trouble here. I’m afraid we do not have any access to Apple’s iTunes App Store, so we’re not able to see what the issue is here. That said, Apple does have a helpful troubleshooting support article for this issue here:

If you continue to have trouble with connecting to the iTunes App Store, I might suggest contacting Apple directly:

In the meantime, please let us know if you have any further questions, or if we can be of any help on our end.

Bad luck! And sorry for sending you down the wrong path. I hope Apple support can help you get it sorted.

I just talked to a support rep @ Apple and they had me do various debugging steps and checked on their side and didn’t see any problems on their end. They suggested talking with the developers of OmniFocus.

Being a software engineer, my instinct is always to blame the software which most recently changed ;) Will definitely contact to add my voice to those having trouble.

1 Like

It’s good instinct in general, but in this case there really is nothing our sales team can do. It’s unfortunate that the App Store support team doesn’t understand the mechanisms by which the store works, but this error really isn’t coming from us. Steps that have worked for other customers in the past:

  • Rebooting
  • Reconnecting their network connection
  • Signing out/back into the store
  • Calling Apple (in some cases there has been a fraud protection situation)
  • Waiting

I wish we could do more to help customers troubleshoot in these situations; one thing that we’ve discussed is catching that error message and replacing it with our own that’s explicit about the source of the problem and provides some version of the above steps.


I understand that the error is coming from Apple, but my point was that since OmniFocus 3 is a new piece of software. Furthermore while you went through a beta period, I would assume that this code path isn’t as thoroughly tested because users would only hit it when they are buying the app (something that you don’t do with the beta). I suggest all of these things because I’ve done all of the things that you’ve suggested and more (see my E-Mail to

I may be unaware of the effort that your development team went through to test out OmniFocus and particularly the in-app purchase feature, but I would ask perhaps they could check if there have been any changes in version 3 with that workflow in the way the OmniFocus code as it is connecting to the app store. Maybe a long shot, I understand. I’m also happy to help troubleshoot the problem.

And I realize that the App Store is probably the bain of existence for OmniGroup’s support / sales staff ;) I would happy switch my license to a non-Mac store version so that both you and I don’t have to deal with this in the future (though in my many attempts to fix this problem I also found your article saying that you can’t do that)

Ok, well that’s fixed now. Sorry about that ;(

I decided to buy a $0.99 app from the App Store and it told me my billing information was out of date. I fixed that (which was actually the address I had in there before I started debugging, but there must have been something else wrong at the time) and now I’m able to purchase OF3 Pro.

I’m sure you’ve probably looked into this, but does the App Store send you back a description of what’s wrong? It would probably save you a lot of support headaches to pass that along if so, but knowing the sort of support headaches that you have with this issue, again, you’ve probably already tried.

Anyway, thanks, and sorry again!

I thought I posted a follow up here, but I’m not seeing it…

Suffice it to say I figured it out by buying a $0.99 app from the App Store and it led me through updating my billing information (which was the billing information which I had before I started debugging, but there must have been something else wrong).

Sorry about that!

1 Like

Hi, I’m having the same problem but the solution does not work for me. When I try to unlock pro after trying the free version i get this error message “SKErrorDomain error 0”. To troubleshoot I tried to purchase an app from the App store on the same computer and it went through without problems.

I guess I could try reinstalling Omnifocus but I’m worried I may loose the database (I use Omnisync).

Any other toughts om how to solve this? Since I can buy stuff from the appstore this seems to me to be an Omnifocus-specific problem.

Thanks in advance


I have the exact same problem. I bought the uppgrade on IOS and that worked! But on my MAC I get this error: The operation couldn’t be completed. (SKErrorDomain error 0.)

Did you go through the steps listed above?

If you did and you’re still stuck, please email or call +1 800-315-6664 so that we can make an attempt to help.