OmniFocus on iPhone crashes and takes long to synch

Hi all,

I have been experiencing this issue for a couple of days now. I am not sure if it’s due to my internet connection, but currently, whenever I try to synch my OF on my iPhone, I keep seeing the spinning wheel on a dark gray larger rectangle in the middle of the screen (sorry I cannot attach a picture).

When I close the app, I do not see the little badge with the number of due items.

Sometimes the app freezes. I was waiting for the spinning wheel on the grey background to finish, but in the meantime, I got a notification for a due task with two options: “Close” and “View”. I tried clicking on both. but nothing is happening. When I close the app and reopen it, I see exactly the same screen.

Any suggestions on what to do?

The best way to get support for a specific issue is to contact our Support Humans at +1 206-523-4152 or 800-315-OMNI or

They can walk you through steps to figure out why sync is misbehaving, and hopefully get it running smoothly for you again.

The freeze is something some other folks have reported directly to us and in this thread. We’re not sure what’s causing it yet, but every person who reports it gives us another clue. (Knowing it can happen with an alert up, for example, is new information.)

Hi Lizard,

I actually restarted my phone, and now it’s working fine.

Thanks for the tips. It’s great to know that there is human support too!

I’ve seen something similar with the iPhone app. There have been a few occasions when I start the app, it seems to behave normally for a few seconds, and then it becomes unresponsive or a translucent fray rectangle appears, with the loading/cog symbol appearing in the middle, but it then stays that way. I’m presuming it is caused by a syncing issue. I’ve tried using both 3G and WiFi, in case there was a network problem that was causing syncing difficulties.

I tried closing the app and restarting it, but ran into the same problems. Sometimes the app crashed, dumping me back to the home screen of iOS, but the app would still be running. Whether I went straight back into the app or first tried closing the app (before loading it again), the result would be the same. Like you, Anna, I found restarting my phone seemed to solve the problem!

Fortunately, it’s been an infrequent bug overall, but it did bother me quite a lot because it made the app unusable unless I restarted my phone. There was one day when OmniFocus was locking up frequently and I had to stop using it. I’m usually very diligent about closing apps that I am not using. I am now leaving the OmniFocus app running constantly in the background, never closing it, and the problem has not reappeared since. So it could be a coincidence, but I wonder if that is an alternative solution to restarting your phone. If I learn anything new, I’ll be sure to post it.

For the OmniFocus team, I’ll provide technical details in case they help to track down the cause:

iPhone model: 4s

iOS version: 8.1.3

Network usage at the time: Either 3G or WiFi. Internet access was fine at the time.

What I was doing prior to the issue: I had just loaded the app. Accessing the Inbox, Projects, etc. or manually initialising a sync would reliably bring on the problem, but checking Perspectives seemed safe once or twice.

Sync: With Omni Sync Server

Reminders Capture used: Yes, although I rarely use Reminders now (so yes only in theory?)

Calendar alarms: Yes

OmniFocus in Today list: Yes

Custom keyboard: No

If any other information would be useful, please let me know. I think OmniFocus is a useful app and I’m glad to help in any way I can.

If you send me your email address by private message, or email with a link to this discourse thread, I can look up the crashes you sent in and see if they’re something we’ve addressed or something we still need details on.

Sorry for the misbehavior.

1 Like

Thanks, Lizard. I’m not seeing problems while leaving the app running, but I’m happy to talk to you about what I experienced previously and to help with troubleshooting. Private message sent!