Omnifocus pushing to iCal

I have been using Omnifocus for years, and was using a legacy feature of Omnifocus pushing to my iCal calendar my tasks. With the new layout of Omni, it really is redundant and would like to disable the feature, however, there seems to be no way to remove it anymore. It was under the sync preferences, but now there is no way to remove/disable it as far as I can find. Any reference to it online is in regards to old versions of Omnifocus. Can anyone help me out or point me to somewhere?

@Can8dnBen, I think that all you need to do is to go into your System Preferences, Security and Privacy Control Panel, select the Calendars control and de-select Omnifocus. Does that work?


If you’re talking about this preference, it’s still there:

1 Like

Yes, I did find that as well, and it was already set to “off”. I also reset to defaults on the page there to no avail. Still being pushed…

Update 1: I found that this is being pushed to my .me account and maybe a work around of my own creation. checking out my settings there to see if I can stop the push.

Update 2: I have removed access via security and privacy control ask per @mr_rique suggested, and the only way I can turn off the push is if I disable my .me using the calendar completely (which is obviously not a solution). I need to find the link between Omni pushing to my .me now.

Final Update: I went into each of my devices, went to the Omni reminder account I created within my .me account and then removed it. Sorted. It was all my side and was a workaround from ages ago. Many thanks for the info.

Good to hear. As far as I know, the system’s security and privacy controls should be for OmniFocus reading your calendars (or writing to your main calendars, if it did that).
But the thing you wanted to disable was Calendar retrieving events from a calendar that OmniFocus was publishing to a separate place.
So, it sounds like one of your devices was still publishing that calendar. (And the Calendar app was still subscribed to it.)

I have a quirky problem … I set up the connecting of my Omni2 into iCal, via the Notifications preference. I was wondering about the changing of items in ical got reflected in Omni, so I think attempted to resubscribe, can’t remember what/if I did anything els e – but NOW I have duplicate items showing up in my iCal & can find no way to disable this. I’d like to start afresh, but nothing I’ve tried seems to work .
I removed the iCal to Omni direction, reinstated, I’ve closed iCal/omni, rebooted my Mac … tried to ‘resubscribe’ the calendar & it told me I was already subscribed - but didn’t appear to do that when I inadvertently set up a 2nd account. BTW - one is brown, the other is yellow, as far as colors showing in my iCal.

I would like to see the reminders in my iCal, but not twice!!!

Any ideas???


(Oh, & I do not have Omni items showing on my iCal on my iPad - not even sure how I would set that up, even if I wanted to …)