OmniFocus1 not opening after MacOS upgrade to High Sierra


#1

I just finally upgraded a 2011 MacBook AIr from Mavericks (10.9) to High Sierra (10.13) and am sad to see that my good old OF1 workhorse is no longer opening for me. I appreciate that I’ll eventually need to update OF, but was hoping to do so once OF3 is available for all platforms.

Console shows the following errors upon trying to start up OF1:

=======================================

default 21:23:44.230177 -0400 OmniFocus /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8

default 21:23:44.230276 -0400 OmniFocus /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file ‘/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist’

=======================================

I’ll start looking into the possibility of re-installing OF1 on this Mac from the downloads page, but was curious if anybody else had encountered/resolved any such issues before I go too far down this rabbit hole.

Cheers,
Remo


#2

Alternatively you could upgrade to OF2 now, as you then will get OF3 for free.


#3

True that, thanks for the possibility to consider. I do already have another device already on OF2, though (as they were setup separately at the time), and would prefer to do a full “family plan” upgrade of all of such devices to OF3 at once, if still possible. This problematic one just happens to be one of my OF1 stragglers.