OmniPlan doc file size


#1

Hi,
as a freelancer I keep different projects for various customers and sync my availability for resource planning via my E-Mail account, This works perfectly. But for quite some time I have noticed that the file size increases dramatically over time. As soon as I export as MS Project file and import again into OP, the file size shrinks from 15 MB to 150 kB. The friendly support ninjas at Omnigroup could not offer me a clue how this happens. Sadly, the increase in file size degrades performance especially when syncing.
Has anyone come across this strange behavior and perhaps found a way to reduces file size?
Exporting and importing does not solve the problem, as important data get lost on the way and I have to rework the plans. Oh, I have no attachments or anything, no change tracking, nothing.

Any help welcome.
Thomas


#2

Thomas,

Thanks for your post. I wish I had a solution for you, because I have a similar problem. I am not using MS Project at all, but I had a project that was 700 or 800 kb in OmniPlan. Now in OmniPlan 2 when I add calendar subscriptions, the file kept getting larger without me adding in new tasks or significantly changing data. Eventually it was 40+ MB, and the program would crash all of the time and I could not level it. I spoke with Support on the phone [OG #1154133] , but we only got as far as recovering the program so that I could open a previous version.

I also tried to create a new file with 1 Resource, 1 Apple Calendar subscription and four 1-day tasks. The file size immediately jumped up to 4 MB.

On existing projects, trying to work backwards to reduce a file size, I removed all but 1 resource, all Subscriptions/Publications, and eventually deleted all but one task and I could not get the file smaller than 12.2 MB. Exporting all data to a .csv did not show any obvious signs of problem with my data, so it may be a chunk of the file I don’t know how to reach.

Also, on existing plans if I attempted to add a calendar subscription for a project that started back in 2007, I am unable to get new calendar data into my plan past about 12/2010 or so. I am also having problems with leveling adding in tons of extra time between tasks (years in some cases) as well as the program chaing 100% complete tasks to >99% (which if I understand correctly is altering the leveling as well).

I understand your frustration. This feature was the primary reason I upgraded to OmniPlan 2, and really wish the problem could be resolved.

Thanks,
cemk


#3

Thanks for your answer. I thought the increase in file size had something to do with tracking. Instead it seems to be the calendar data caching. That is one of my frustrations as well: these calendars sometimes do not refresh. So just removing calendars and adding them once in a while could help. I will try and post back.


#4

Please let me know how this goes. I have also tried that and then found none of the data from the calendar would appear or it stopped as of 12/2010.

Thanks,
cemk


#5

Ok, I removed the calendars completely and myself (as the sole resource. The file size increased from 12.5 MB to 12.9 MB. Then I added myself and the the calendar entries, updated - and the file size went up to 13.1 MB.
This is ridiculous, because I need to sync the project files across the OmniSync server. This in turn blows up the space on the server - which should not be in everyone’s interest.


#6

Thanks. I’m glad I have company in this misery!

I sent Support an updated and lengthy update on my issues. I will let you know what happens.

Update: 8/1/14 - Still waiting to hear back from support.


#7

This seems to be an issue either deep down the list or deep down in the apps intestines. Either way, the files keep bloating: from 13 MB to 22 MB with only half the number of items.


#8

OK, now, about 600 days later, with OP 3.3.3, the problem still persists. Files keep bloating and the only way is to return to an older format, then reimporting and editing. Seems like an issue no one else seems to have.
Strange.


#9

@samoht Sorry for the continued trouble with this! Would you mind sending a follow up email to our Support team about this? I took a quick look in our ticket database for your prior communication with the team but I wasn’t able to dig it up. Hopefully we can track this issue down this time around!


#11

Good afternoon,

my file is now nearly 900 MB!! I sent a mail to support, but no answer. Please help! :(

Alex


#12

@alexred Sorry for the trouble, and the slight delay in response! It looks like you have a ticket open with Shane on our Support team now - he should be able to help you get back up and running with your file!