Omniweb 6 on Yosemite crashes. Cannot open at all


#1

(6.0 test (v626.0.220447) (Oct 27 2014).

Tried the usual tricks. Deleting preferences. Would like to start over. IS there a link to the test version?

Crash reports filed.

Thanks.


#2

It’s happening to me as well. Going off of some insider info, we likely will be able to track down the bug quickly! I’ll file a bug for us.


#3

Same here. This is what I get from the console:

/Applications/OmniWeb.app/Contents/MacOS/OmniWeb 
OCCCrashCatcher: Not enabling crash catching since we're connected to a tty (and thus presumably in gdb)
Assertion failed: ([[NSApplication sharedApplication] class] == [OAApplication class]), function main, file /Volumes/Local/Shared/omnibuild/ReleaseProduct/Source/OmniGroup/Applications/OmniWeb/Source/OmniWeb_main.m, line 61.
Abort trap: 6

It’s reproducable, if necessary I can pass on the trap details.

I do NOT use the crash report util since there is no way to copy and paste the crash report into my mail client of choice. This should really be changed as this keeps people from sending crash reports.


#4

Sorry! This should be fixed in the next build (revision 220467 or later).


#5

Can you post a link to the download? Can’t update from the browser obviously.

Thanks.


#6

Sure – the downloads are here http://omnistaging.omnigroup.com/omniweb/


#7

Thank you for posting this. Up and running again.


#9

I’m still having difficulties with the newest Omniweb version (OmniWeb-r221715-Test). After installation, it simply hangs and I have to force quit. I cannot send the crash report. I just installed the Yosemite update, still no success.
I’m still using OmniWeb-r220782-Test, which works.
Any ideas?


#10

Check for updates. Download. Latest version won’t open again. It’s a free app, so what right have I to complain? But come on.


#11

Same problem here.


#13

The newest version seems to work again, I just installed it.

(Date: 2014-12-18 20:45:13 -0800
Builder: omnibuild
Host: tb1010b.private.omnigroup.com
Revision: 223333


#14

I’ve been running an earlier test build under Mavericks on my old Core 2 Duo MBP, and just moved to a current generation 15" 2.5 GHz rMBP running Yosemite 10.10.2. When Omniweb offered an update, I accepted, not realizing that OW no longer archives the old version. The new test build never opens a workspace, showing “Application Not Responding” in Activity Monitor.

I’ve now tried every single currently posted test build, but none of them run. I was able to retrieve the version I was running under Mavericks from a backup. It runs, but with some issues - scrolling, in particular, is very problematic.

I realize these are test builds, but I’d think that they would at least run under Yosemite.


#15

I’ve also had the Omniweb hang on both launch and quit. Running OS 10.10.2

The work around I use is to move the bookmarks and favorites file from the user>Library>Application Support>Omniweb 5
(You can get to the Library from the desktop by holding the option key and clicking on Go in the finder menu at the very top.)

Omniweb generates new bookmarks and favorites files on its own, but that doesn’t solve the issue long term. It still gets funky and hangs when you update or add bookmarks or favorites.


#16

None of the release will work on OSX 10.11.x - instant quit on any url load. please fix as we love your browser.


#17

I just got an macbook as an gift from my blogger friend “Gustavo Woltmann
Am also suffering this crashes while using Omniweb 6 on my mackbook (os 10.10.3)
I checked for updates download it but not solved yet.
Anybody here for solving this issue please? :(

Have a nice day.