Outline Print upside down

when I updated t MacOS Monterey, I started having this problem where if try to print the outline it shows the tasks in upside down and mirrored font, I also had the same issue when trying to create a report.
anyone might know a solution?

3 Likes

I’m still in search of a fix, I’ve tried multiple PDF Printers, CSV formats, mpp (only exports the first task), so far nothing works.
I’ve booted up Big Sur from an external SSD and the file worked normally and printed just fine.
I’ve tried Omniplan 4 as a view (from the app store, and through dmg) and the problem remains.
I initially thought it might be a PDFkit issue, but all other programs work just fine.

So far the only workaround is to prepare the file on Monterey and print it through Big Sur ( not practical at all, but I haven’t found any solution yet)

I’m seeing the same issue here… also on Monterey

I’ve been using Monterey for several months now (Public Beta). I am facing the same issue now, and it manifested itself only in the last couple of weeks.
I’ve tried removing older tasks, different fonts but no luck unfortunately. Any ideas? I am already late with my project reporting. :(

Do make sure you report this through Help > Contact Omni...

(I believe that there is a bug in Apple’s image resizing/resampling logic which can flip images at particular levels of resize – there are occasional mentions in the context of Preview and other apps – it may be worth fiddling a little with any printer settings that might tweak scaling, for example trying fractionally off 100% under dimensions in the print dialog)

My fix was to export it as OmniOutliner and it looked fine. Not optimal but workable.

Pull it into OmniOutliner.

OmniOutliner is printing fine, but I need the Gantt chart and the others, so for now the only fix I found is switching back and forth between OS, doing the majority of the work on my MacBook (Monterey) and printing on my iMac ( Big Sur).
I tried everything so far ( fonts, styles, printers, scaling, scripts, exporting…) all to no avail :(

Same issue here. Used Skitch to take a screen shot of the Gantt chart. Not ideal at all…

Also seeing the same problem, workaround is to open the file on BigSur and print from there (also screen shots).

Same issue. I’ve checked all of my projects and they only export upside down. I contacted support. I hope this is resolved soon because that’s our main use for the program.