Paste into multiple rows

Hello,

I’m fairly new to OmniOutliner and quite happy with it overall. One item that eludes me is a way to copy multiple lines of text from another application (multiple lines from a text file or multiple rows from Excel) and paste these as multiple rows in an outline.

If I click in a row in OO and paste, everything is placed in that row.

If I highlight a row in OO and paste, I get different results depending on the source:

  • Pasting from excel results in an embedded image
  • Pasting from a text file results in a number of new empty rows equal to the number of lines of text

I’m using OO Pro 4.4.1

Any suggestions would be appreciated.

Thank you

Pasting while a row is highlighted is the correct way to do it. The issue of Excel giving you an image has been fixed in our 4.4.2 test builds.

1 Like

This may have been fixed in 4.4.2, but it’s broken again in 4.6.1: Excel (and Numbers) pastes as a graphic in a single row/column.

Which version of Excel have you tried? It pastes correctly from Office 2011, I don’t have access to 2016 right now, but at least the latest version of Numbers is resulting in an image. Some else appears to have changed, possibly with how the OS handles pasteboard content as Excel 2011 is always pasting correctly even before the fix mentioned above.

I’m using the latest Excel, v15.28 — and the latest Numbers. Pastes as an image from both.

Does this issue persist? I am trying to copy and paste one column from Excel (15.28) into OO (4.6.1), but it is pasting an image. I selected the whole column in OO, but I still get an image pasted.

This is not working in version 5.12 using raw text with line breaks. Is there a plan to fix this? Excel does seem to work, but that is a workaround for me.

It’s working for me in my tests. Could you please elaborate on what’s happening for you? Are you getting everything inserted into a single new row? Is it creating a new row(s)? It is important to make sure you’re pasting as new rows, not into an existing row.

Everything is inserted into a single row, even when the row is highlighted.

And it is getting inserted into a new row, correct? Not the row you highlighted. It may have something to do with the source data but I’d need something to look at. Does it happen if you copy the text below?

1
2
3
4
5

Wow - thanks for pointing this out. One of my weekly tasks involves copying a list from a web-app into OO. I’ve been copying and pasting each line individually for the last 18 months - now I know the trick to paste into a new row (by having a preceding row highlighted) rather than into the current row.