Perspective from Mac not displaying tasks on iOS

Hi, I have the following perspective working well on Mac, but it says on iOS “no items match this perspective”

On the Mac, several contexts (many nested) are selected. On iOS, the same contexts are listed as selected.

On the Mac, many tasks appear in this perspective.

Without seeing the status of your contexts and tasks, it is hard to know what the cause is, but here are a few steps that might help you isolate why these tasks aren’t showing on iOS.

In the Perspective Settings

  1. Change Filter by Availability to “All”. If tasks then show up, the task status is what is blocking them from showing.
  2. Change Filter by Context to “All Contexts”. If tasks then show up, the context status is what is blocking them from showing.

Hope this helps!

I have a similar problem with the built in completed perspective. The mac and the ios perspective have identical settings. The Mac version shows 20 completed tasks. IOS (both phone and ipad) show zero. I’m stumped.

If you search everything for one of the tasks that isn’t showing on iOS, is it showing up in search results? If you change your completed perspective view to show remaining, then to show all again on the iOS perspective, does that show your completed items? Sorry about the trouble.

Thanks for your help.

It hasn’t worked to toggle any of the settings. I created a new perspective with the same settings and it works.

The default completed perspective works as expected on the Mac, but I can’t get it to work on two device

Hi Steve,

I’m sorry that those changes didn’t help. I was hoping that somehow a setting didn’t get synced over & by toggling them they would sort themselves out. I’m glad you found a workaround in a new perspective.

It might be best to get you in touch with support so they can diagnose what happened with the Completed perspective in more detail. Email omnifocus-ios@omnigroup.com with a link to this forum post so that they will know what you’ve tried so far.

Thanks,
Lanette

I was just about ready to send the email and I decided to try one last thing-- revert perspective to default settings. I don’t know what was wrong, but it fixed the problem on all of my ios devices.

Congrats on finding the fix!

That means somehow a setting other than default was set in your Completed perspective, at least behind the scenes. If this happens again, Show Perspectives, then drag out the Perspective to your desktop on the Mac. This way you can open the Perspective and read the settings in a text editor to know exactly which setting was the culprit! I’m glad you got it resolved.

1 Like