Perspective Widgets not showing on iOS

I just updated to iOS 15.2 and widgets no longer populate with a perspective. I’ve reinstalled OF, restarted phone… does anyone else have this problem?

+1, same problem here, iPad and iPhone

Still not working ipad or iphone.

I contacted support and went through everything with them…
There wasn’t anything they could do, but they said it was a known problem.
Then about a week ago the widgets started working

The other problem i have now is the apple watch widget no longer allows me to capture.

Omni Support pushed me in the right direction. Database size was the problem in my case. I archived every completed project before Dec. 31, 2020, and now the widgets started working again. It’s a bug somewhere, of course, but maybe this tip will help others too.


It might not be a bug: Could OmniFocus be running out of processing budget - with a database of that size?

“That size” implies a huge database. That wasn’t the case. I archived around three years and I do not store attachments in OmniFocus.

1 Like

I’m speculating: “Size” can mean “number of items” as much as “physical size”.

I’m still having this problem. Anyone else?

What’s happening for you? Widgets now work for me

Still just blank. If you tap it, it goes to the appropriate place, but the widget itself is pretty worthless. I’ve tried reinstalling a couple of times, but that turns it to more work rearranging perspectives etc., so I’m trying to figure out if this this fixed before I try that again.

Are you up to date on ios? I updated, and then reinstalled everything and it worked… but it was kind of a hassle. With that said, even today, i changed a widget perspective and it went blank for like an hour. And then it suddenly came back. Not sure if that helps, but hopefully it’s fixed soon for you because it’s super annoying not being able to see it. It’s like once the precedent is set, it’s hard to go back haha.

Yep, everything is up-to-date. If fact, I got a new phone in early January, and the widget worked on it for about an hour and not since. I leave it on there so I will know if it starts working again. I should probably just delete it because I think that is what finally bothers me enough to come post on here. Thanks for your help.

I installed the Omnifocus widget on my iPhone SE and on my iPad mini (current IOS version 15.3.1). There have never been any problems.
Note: If you put the new widget on the home screen, you have to press on the widget and select “edit widget” and then set the desired perspective.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.