Plug-In won’t install

I can install the sample plug-ins on iOS but when I try to send my own plug-in, from Scriptable as a .js file, OF tries to add a task to the Inbox rather than importing my plug-in. What can I do to get my plug-in to install?

Are you trying to install a Solitary Plug-In ? If that is the case, it has .omnijs file extension. Or, perhaps this is one of your Plug-In bundle files ?

Changing the extension (an ordeal in iOS…) didn’t help. I’ve been trying to follow the steps here:

It looks like the plug-in is just a single flat JS file but regardless of extension it’s not triggering the install process when I share it to OF.

Could you give more details on your process ? Are you writing a Plug-In in Scriptable and then using the Share menu of main screen ? If I try to write a plug-in in Scriptable, I do not get OmniFocus in Share Sheet. How do you open the file in OF ?

have you tried using the “plugin creator” on this pge?

it will give you the .omnijs template, and you’ll only have to add your code.

I exported as a .js file to Dropbox then renamed it there to .omnijs and exported to the OF share sheet.

Tried it. It produces a .omnifocusjs file , not .omnijs . iOS now recognizes it as OmniJS Plug-in for OmniFocus and even gives the option to Open in OmniFocus (in iPad OS 14) but unfortunately nothing happens when I click that button.

Same results on my phone with iOS 13, except with the Open in OmniFocus option.

I don’t understand why we can’t just use a file picker and are instead forced to rely on the vagaries of the share sheet.

Ok - I’ve eventually found a solution - change the file extension back to .omnijs , and move it into iCloud Drive > OmniFocus > Plug-ins

I had that as well the first time I used the new options.

What solved it for me was going into the OF app, configuring the OF plugins folder to be on my iCloud drive and then manually moving the files into that folder.
Once I had one in I found I could just open any others and OF would automatically recognize them. No idea why, but it worked for me.

1 Like