Problem with Omnifocus 3 Mac after MACOS Date change

To test some software I adjusted the date and time in macOS manually. Set it a month forward.
Tested the software. Then set it back to ‘automatic’.

Later I opened omnifocus and saw a huge list of available actions. Quickly realised it was showing all the actions from the time perspective of my date experiment (month forward).

I uninstalled Omnifocus and deleted all config files. Reinstalled it and it solved the problem.
But maybe you want to look into this.


I suspect that OF had no choice whenever it compared the availability of its tasks with what it - in all honesty - simply could not help but think was the current time by referencing the system clock as you’d set it.

Not sure how it could act any other way.

Or are you saying that when you set the clock back to the current/correct time/date, OF should have reread the system clock, then reread the dates/times of all its tasks and compared the two - but didn’t?

In which case, presumably we can assume that OF must set an internal flag indicating that an item has become available; but either is unable, or unwilling, to unset it.

Again, I’d have thought that OF legitimately assumes that such a state is impossible or at best unlikely to be encountered in the normal run of things :-)

1 Like

Correct: OF seems not to have re-read the clock after I set it back.
(which adds another curiosity: how and where does it track time then…?)

If this is being looked at by a OF developer: I didn’t actually ‘set the time back’ I switched on “auto set date”. So technically it was MacOS restoring the date back to normal. During the ‘date change’ session Omnifocus was ‘running’ but I didn’t open Omnifocus on the screen.

To recover from this i open and closed Omnifocus with no result.
Restarted the computer. With no result.
Disabled and enabled sync. No results.
Then removed Omnifocus (by moving the app to the garbage bin and deleted the archived databases) With no result.
Had to use a cleaner app to do a full uninstall and cleanup of Omnifocus and then I reinstalled it… and things were back to normal.

I use a Perspective with rules:
Availability: available
Any - Status Due soon

And yes I confirmed that although the system date was 14 November there were Items on the list that had a due date beyond that, according to the Inspector.

Im inclined to ‘do it again’ for testing purposes but I’m still recovering from the shock of 100+ ‘remaining’ todo’s on my list ))

Sorry about that! I’m afraid that, as you’ve discovered, OmniFocus currently assumes that time only marches forward and never backwards.

When you do find yourself needing to travel backwards in time (so to speak), you can get OmniFocus to recalculate every item’s state by choosing Rebuild Database… from the File menu.

Hope this helps!

1 Like

Rebuild database! I didn’t try that. Thank you.

And for time travellers only theory: I’m a developer so I switch dates quite often to test things out )

I do wonder though: if OF can’t handle ‘time travelling’ how does it handle moving in different timezones?

I just reproduced the thing: set the date to 30 November and back.
Omnifocus now still assumes its Nov 30 with all tasks showing.

I tried Rebuild database: that unfortunately doesn’t fix the problem.

I don’t believe it does

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.