[Question] Why won't this task show up in the perspectives?

Hey there!

I encounter this problem with OmniFocus which is driving me nuts. In my “Today” perspective I only see sub-tasks of a task in a project but not the task itself. I attached screen shots so you can see what I mean (I’m German, don’t wonder). To clarify with a real example:

I place backlinks to my website once every 5 days, so “Place Backlink” is a recurring task. As sub-tasks (I dragged them below the “Place Backlink” task) I defined places to check-out for possible backlinks. These sub-tasks show up but not the “Place Backlink” task. It is driving me insane! Does anyone know why?

Here’s the second screen shot. Unfortunately, I can only upload one directly: http://i.imgur.com/xVeg8b3.png

Hi @timg! That looks like a context-based perspective to me (one with contexts in the sidebar, where the option is set to “Don’t use project hierarchy”). In context-based perspectives, your tasks are flattened out, and – by default– only available tasks are visible. OmniFocus does this to try to help emphasize the tasks that are immediately actionable in your database.

I think you’ll find that if you check off all the sub-tasks inside “Place Backlink,” then the action group will become visible, and you can check it off. Until then, though, the “Place Backlink” action group is considered blocked by its children, so won’t be visible by default.

You can make remaining items available by changing the “Filter by availability” setting of your perspective. Changing that to Remaining should start including “Place Backlink” in the list, even though its children are still available. The perspective will still be a flattened list, though; if you really want to see structure, it’ll have to switch to a project-based perspective.

I hope that clarifies some things! Check out the Perspectives section in the OmniFocus user manual for more details, and of course don’t hesitate to get in touch with support if you have more workflow questions. Thanks for using OmniFocus!

Thanks a lot! I use the project-based perspective now. While it isn’t ideal, because I also see all of my other projects I cannot take actions on, it’ll do the trick for now I guess. Thanks! :)

Additionally, if you want to see only that project’s details, you might consider trying the “Focus on [project]” option on the view menu.

1 Like

Also, I believe that @tekl’s solution only works if you have the preference set to include projects and groups in perspectives without hierarchy.


1 Like