Reminders Capture not working since watchOS 2.2


#1

Is this a known bug?

Thx


#2

It is working for me using the latest release of OmniFocus 2.13 on iOS 9.3.1, so not a known issue.

A few things to check:

  1. Go into the Watch app on your phone and make sure that your OmniFocus has Show App and Show in Glances on.
  2. Are you seeing any reminders on your watch at all? Try turning off
    capturing reminders in OmniFocus. Add a reminder for a specific time
    (Soon), and see if you are notified on your watch. If you are being
    notified, but not by OmniFocus, turn reminders capture back on in
    OmniFocus on your phone and try the next steps. If no reminders work on the watch at all, check the Apple support for ideas.
  3. Go into Settings in OmniFocus on the phone and make sure reminders capture is on, and that the list you are using is the list selected. If you don’t have “Reminders” selected as the list, it could be looking at a custom list instead.
  4. Check your notification settings. If those all look good, try fully
    rebooting the watch and iPhone. https://support.apple.com/en-us/HT204510

Note:
There are some kinds of repeating reminders that OmniFocus doesn’t
accept. You can set up hourly, weekly, every 2 weeks on Tuesday, but
if you set up a repeating reminder that OmniFocus can’t read, by
design it will be kept in your Reminders list rather than imported
into OmniFocus, so you don’t lose it. If you can add some reminders, but others do not show in OmniFocus, check the repeating options you are using to make sure it is something OmniFocus allows.

If you still have no luck, please contact our support humans so they
can help. Email to omnifocus@omnigroup.com or phone +1 206-523-4152
or 800-315-OMNI (10a-5p PDT M-F)

#3

It gets added to reminders but never makes it over to OmniFocus. It just goes over to the scheduled list in reminders.


#4

When you added a simple reminder with no repeats due in 5 minutes on your phone, did OmniFocus pick it up?

If not, and you have reminders capture toggled to on and your OmniFocus settings selection to the list you added the reminder to on the phone, something has gone wrong beyond what I could suggest you try here.

If it did work to capture from your phone, but not from the Watch, let support know what kind of reminder you are setting, if it has repeats, locations, or any other details that might help them understand what exactly isn’t working. If it is “all reminders, even a time based one from the phone”, that is not at all expected and I’m pretty sure we can help with that in support.

Please contact a support human who can get you more specific help. Email to omnifocus@omnigroup.com or phone +1 206-523-4152 or 800-315-OMNI (10a-5p PDT M-F).

Thanks,
Lanette


#5

I say “Hey Siri remind me to pickup milk at 5pm.” This works fine on the iPhone itself. If I try on the Watch the reminder goes into another list called “Scheduled.” I presume that’s why OmniFocus isn’t picking it up.


#6

Yes! If you go into OmniFocus on the Phone, and switch your reminders list to “Scheduled” they should show up. Now, you might then need to switch around a few reminders on the iPhone because you can only pick one list to capture from.


#7

There is no way to change it to Scheduled on the phone or in the app itself. It doesn’t show up as an option.


#8

Hi there! This should work, but keep in mind for it to work the right reminders list must first be selected, then your today and watch needs to be set up in the perspective. There are many places this can fail based on what you say when recording your reminder, from what list you have selected in OmniFocus, and what is on the phone. Your best bet is to contact support who will be able to walk you through them one by one. This is working for me, but I’ve walked through all 5 settings that have to be matched up to get it working. Sorry I can’t help further.


#9

I don’t have the Watch - but I can confirm that I can only get OF (latest version on 9.3.1) to pick up Reminders set this way in the ‘Scheduled’ list.

Any attempt to add to any other list using Siri results in Siri asking me if I want to create that list - even though it does already exist.


#10

The Scheduled list in Reminders.app is not a Reminders list, per se. It appears to pull together any items that are scheduled for today, regardless of which list they are in.

The key here may be making sure that the Reminders list that OmniFocus pulls from (according to OmniFocus Settings) is the same list that is selected in Settings.app ‣ Reminders ‣ Default List. If that doesn’t do the trick, please contact our Support Humans: omnifocus-ios@omnigroup.com


#11

If you have multiple lists in Reminders, double check which of those lists OmniFocus is set to capture from. You can do that by opening the OmniFocus settings and selecting the “Reminders” option. That will show you which list is selected for OmniFocus to grab from, it will also show which of those lists is set as the default list for Siri to write to. In the screen shot below you can see that in my case, my “OmniFocus” list is what OmniFocus captures from by the check mark on the right. Also the (Default) means that the same list is set as the default list for Siri to write to.

The “Scheduled” list is similar to what the Forecast view in OmniFocus does. It complies a list of all the things on all the lists that have due dates. So, while a scheduled task would show in that list, it will also appear in the normal list it was added to.

If you try adding a task using the phrasing “Hey Siri, add to my (insert name of your OmniFocus list here) “test reminder” in 5 minutes” does that work?


#12

Thanks, Steve and April!

Yes, I followed all the steps you kindly outline and suggest and the directions on the page in question on the Omni site.

Nothing I can do gets the Siri-instruction task into a Reminders list which I created: Siri asks if I want to create such an (already-existing) list!


#13

Yup, same here.


#14

I’ve found it really matters the exact phrasing that you use for Siri to add the reminder to a non-default list. You might want to file some details with Apple about the exact phrasing you used where the list isn’t placing the reminder where you’ve specified.

Here is a way that is working for me: “Hey Siri, Add to my (Tasks-but you’ll name whatever your list is) list Test the new Apple Watch Beta at 7pm.” If Siri is asking you to add a list, usually that is because it did not interpret your list how you intended it to be interpreted into text. One example is if you say “Add to my OmniFocus list” it may be trying to add a new one called “Omni Focus” because audio is really difficult to parse into text. I think Apple may like to know the exact phrasing you are using that doesn’t work so that more flexibility can be added to audio to text capture. You might try a shorter list name as a test to see if that helps.

Tip to try: Avoid saying “Remind” in what you are telling the watch if you want to use a non-default list. I can’t say “Remind me to do the dishes on my tasks list” and have that work. However, “Hey Siri, Add to my “Tasks” list to pick up pizza at 6pm tonight.” works.

Siri is pretty cool, but sometimes she hears things differently than I intend. That may be happening with you as well. I hope some of these ideas can help you find a way to sweet talk Siri into using the list intended.


#15

Thanks, Lanette - that’s really helpful,

As things stand, I’m happy - because it works - to let my Siri Reminders go where Siri wants to put them.

It was only my idea of wanting to ‘ringfence’ just those Reminders destined for OF that prompted me to create such a dedicated list.

I can well believe that the syntax to which Siri responds best is quite particular.

I also tried ‘OF’ (that is “Oh Eff”), which failed as well.

Likewise “Test”.

… … …