Remove magnets from existing lines


#1

I just spent half an hour carefully creating a diagram. Then repositioned one line to which many other lines were attached, and everything went wonky. Undo did not restore my original. I have a mess now.

I was right then and there ready to ditch Omnigraffle.

Searching online I found a way to disable magnets for newly created lines, but how do I disable them for my current diagram so that I can attempt to correct it?

I’m using Omnigraffle 7.7.1 for Mac.


#2

Check under File>Revert to,…Browse all Versions and see if you have any versions as a backup that might get you back to where you were.

Do you mean using the option key so that lines won’t connect to objects by default? If you want to set that for your lines so they are stand alone lines and not defined by connections, select the lines, and in properties uncheck “Allow connections to other objects” and “Allow connections from lines”. Then your lines will stay right where you put them and will not move based on what they are connected to. Is that what you are looking to accomplish?

Sorry for the trouble with undo! That is not in any way ideal. I do hope you are able to revert.

Thanks,
Lanette


#3

The way the lines link together can be a real PITA. Most of my drawing is without any connectors on because of this issue.

Try this: on the layer with your lines, select all the lines (Command + A makes it pretty easy or you can click on one and then Command Click to select the rest).

Open the Inspector (if not already open) and select the Properties page. You should see a heading for “Connections” with check boxes. If you just want to free-hand it, uncheck all the boxes. Checking just the first two should allow just lines to connect but I find it finicky and only use them if absolutely necessary.

You might also check to see if Snap to Grid is on but sometimes that can be handy.

You might also upgrade to the newer version, at least 7.10.2 which corrected many issues.

Hope this helps.


#4

Thank you everyone! It’s good to know about the revert feature. I ended up correcting everything manually.

I unchecked the two connection options before highlighting everything and then again after highlighting everything. Magnets no longer show when I ask to view them, but everything is still connected.

It seems that I have to get it right when I create the objects, can’t correct afterward.

I tried to use the “Check for updates…” menu item, but it tells me that 7.7.1 is the newest version. See attached.


#5

Are you running El Capitan? I believe you need High Sierra or more to run the more recent versions.


#6

I’m on Sierra 10.12.6.

I’m also struggling with all connections turned off. It’s hard to get lines to route properly.


#7

If you can upgrade to High Sierra, it will give you some newer versions as an option.

Can you describe the problem you are having with line routing? A screen shot may help.


#8

Can you describe the problem you are having with line routing? A screen shot may help.

Sure. I want to connect two objects with an L-shaped line instead of a straight line. I’ve done it a thousand times using magnets. I’m having to double-click to add a point to the line to do it without magnets, and that’s still hard to get right.


#9

Ah! I think I’ve learned a trick. I can just select lines and turn off connections from lines. Now I can have magnets back and function.


#10

THANK YOU for you help everyone! I’m feeling in control again. I just needed to learn a new Omnigraffle skill. I’m loving Omnigraffle again!


#11

For some of that where I need to line up lines, I find using “Snap to Grid” works better than the magnets. It means I have to move some things around but get about the same result without some of the wierd snaps to objects.

You can adjust your grid lines in the Inspector - Canvas page. But note the first item is Major Grid Spacing; the second is Minor Grid Steps (how many minor lines between Major lines).


#12

I find using “Snap to Grid” works better than the magnets.

Thank you for sharing that option! I’ll give it a go.