Remove sounds/noises when entering keyboard shortcuts

Hi,

I am trying to figure out how to eliminate annoying noises that my computer makes when I am entering keyboard shortcuts in omnifocus, can you please help?

I use keyboard shortcuts often to set defer dates in omnifocus. I use Keyboard Maestro to trigger the keyboard shortcut via typed strings (rather than single hotkeys). For example, I type D!D to defer the task by one day. Example below.

The issue is that my computer makes loud noises whenever i hit shift and the D key to enter this macro. Is there any easy way to stop my computer/omnifocus from making this noise whenever I do this?

Thanks,
Dan

are you sure it’s not keyboard maestro making the noise on expansion?
I’d check there first?

1 Like

Yes, I just checked that again and omnifocus makes this noise whenever I hit a key (or a key+modifier key) that has no function.

I also just tested it in the Calendar and Notes apps with random keys and found that it makes this same noise whenever I hit a key (or a key+modifier key) that doesn’t have a function in those apps as well. So it seems that this is sound is being produced by Mac OS, not omnifocus.

Does anyone know if there’s any way to make it so that the Mac OS doesn’t make this sound?

I would be happy to disable it for just omnifocus or for all applications, either way would work well.