[Resolved] Omnifocus on Watch no longer syncing


#1

Today OmniFocus stopped syncing with my watch. I have uninstalled OmniFocus on the watch and phone and reinstalled but still no luck.

Any help would be appreciated.


OF Apple Watch app won't sync
#2

Hey, sorry to hear OmniFocus on your Apple Watch has gotten stuck! If you haven’t already done so, please try restarting both your iPhone and your Apple Watch. If that doesn’t do the trick, you’re best shot should be trying the following:

  1. Unpair your Apple Watch and iPhone. Unpairing can lose things like HealthKit data, so if that’s a concern you’ll want to make a backup first. Apple’s support article on how to unpair can be found here: https://support.apple.com/en-us/HT204568

  2. Restart your iPhone and Apple Watch.

  3. Set up pairing between your watch and phone again.

  4. Install the OmniFocus app for Apple Watch again.

Hope that helps! If you continue having issues, though, please email us so we can troubleshoot this further with you.


#3

About an hour after the re install of OmniFocus on the iPhone and watch it synced. Probably just took a long time to rsync everything to the watch after the reinstall. I do generate about 900~tasks a month


#4

Next time this happens just try adding a new task


#5

I just tried a lot of things. I don’t just typically ask a forum for help. But thank for your advice.


#6

I’ve had this issue a number of times, and it seems like it’s related to the “custom perspective” feature. I would launch the app on the watch, and it would tell me to launch it on the phone, and I’d launch it on the phone and nothing would happen. Just now, I managed to get it syncing again by going to the app on the phone and unchecking “use a custom perspective”. Tellingly, when I did this, the app on the watch crashed. I launched the app on the watch again, and when it finished launching it had my data. Then, I turned “use a custom perspective” back on again, and everything seems to be working great.


#7

I just had this problem for I think the second time, but I couldn’t remember how I fixed it the first time. Restarting my Watch and iPhone didn’t help, neither did uninstalling Omnifocus on my Watch. However, your solution worked.

Thanks!


#8

This is happening again, but now changing the Today/Watch setting from a custom perspective is no longer working. I haven’t tried the unpairing, resetting, re-pairing thing yet and not up to it now as it is tedious and takes a while. This problem is occurring too often.

Have you all changed something that affects this bug?


#9

After having this happen a couple more times, the best way to fix this is:

  1. Go into Watch app on iPhone, find Omnifocus in the list of installed apps, tap on it, and turn off “Show App on Apple Watch”.
  2. Wait for it to uninstall and then tap “Show App on Apple Watch" again.
  3. Wait for it to reinstall and open Omnifocus on iPhone and Watch.
  4. Wait again a few minutes and Watch will be updated with the current tasks.

Note that changing from the custom perspective to one of the built in perspectives no longer fixes this. The above takes a few minutes but it’s easy and works.

If you have a complication for Omnifocus, it will disappear during step 2 and reappear in step 3; there’s no need to change it.

During step 4, the Watch will be asking you to open Omnifocus on your iPhone for longer than seems reasonable, but that’s ok.


#10

I am having the same problem. I did some troubleshooting and noticed that when I add actions to Omnifocus on Apple Watch using Siri, it will have problems syncing to iPhone.

  1. I tried using Siri to add an action to OF on AW by saying “Hey Siri add tea to Omnifocus list”, but it doesn’t add the action into OF on AW.
  2. AW will give a message asking me to open Omnifocus.
  3. When I opened OF on AW, the action “test” is not there.
  4. I tried it again with OF opened on AW, it still doesn’t add the action to OF on AW.
  5. When I looked at OF on iPhone, two actions for “tea” is added in OF on iPhone instead.
  6. When I go back to OF on AW, these two actions for “tea” is not synced there.
  7. After that OF on AW doesn’t sync to OF on iPhone anymore.

I hope the above makes sense to you and helps in troubleshooting the problem.