Rotate skews image


#1

I have a simple image. I cannot rotate it without the connectors skewing. I can’t see how to draw a line without it becoming a connector. Here’s a MOSFET after a 90 degree rotation. It’s broken. I can’t show you the progression because apparently as a new user I can’t attach more than one image.

How do I make the image actually rotate, and not skew isometrically?

This is ridiculous default behaviour for a diagramming application, presuming it’s not a bug. It was also very expensive.


#2

If that is a placed image, undo your rotation. Then, in the Geometry area of the Object Inspector, choose Maintain Aspect Ratio. We have a free update coming soon (OmniGraffle version 7.10) that changes the default of placed images to Maintain Aspect Ratio. If you’d prefer to use that version now, it’s at https://omnistaging.omnigroup.com/omnigraffle/. We’ve changed the default based on customer requests, so if there is anything we can do to make OmniGraffle more useful for you, feel free to email us at Contact Omni from the Help menu.

Thanks,
Lanette


#3

I’ve tried that and it doesn’t work. Even with the image set to “maintain aspect ratio” rotation skews the lines:


#4

Could you please send us an example document so that we can take a look? Choose Contact Omni from the Help menu, or email us a omnigraffle@omnigroup.com.

Thanks,
Lanette


#5

I’ve sent an example file.

Since I couldn’t attach it earlier, this is an example of what the unrotated images look like (note that all the lines are orthogonal):


#6

If you want to draw a line without it connecting, you can turn off these items in the connection inspector with the line(s) selected. You can also hold Option while drawing the line so it won’t connect to a graphic temporarily. The other thing you can do is convert lines to a shape by choosing Edit>Object>Convert Line to Shape.

I realized that you might have connecting lines when what you really want are specific shapes and not lines. When you have a line that connects 2 graphics, by default, it doesn’t have a specific geometry and is defined only as connecting those graphics. This is so that you can create flexible diagrams without losing your connections. While lines that adapt are good for diagramming, they aren’t ideal for drawing as the lines will not stay in a static position relative to the graphics they connect. I believe some of the options above may be of help. If you want those lines to be a shape and never defined by what it’s connected to, Edit>Object>Convert Line to Shape may be your best option. I see what you are seeing now. I thought you had placed in image into the application rather than drawn or created it. Sorry for the confusion.

Thanks,
Lanette


#7

I cannot convert the connectors to a shape; I don’t have the “Edit>Object” menu item. From an internet search this appears to be a pro-only feature.

Turning off “Allow connections…” (the two check boxes in your screen shot) doesn’t fix the problem. I still can’t rotate the lines.


#8

Because those lines are already connected, you need to disconnect them, then with those checkboxes unchecked, move them back into place and regroup them because they are already connected to the other line. Sorry for the difficulty. In the future, when drawing lines that aren’t connections, if you uncheck those first they will not create connections.

If it is difficult to find the areas with connections, try ungrouping your groups. Select the lines inside. Make sure Allow Connections is unchecked for all of them. You can tell which line is the problem, because the points will have a green head showing it is connected when selected. You can also tell because when that line is selected by itself there will be no geometry showing in the geometry inspector.

I hope this helps. Once again sorry this is so difficult to solve in Standard once you’ve got existing connections.

Thanks,
Lanette


#9

Ok, recreating the image without “allow connections…” enabled seems to be working.

Thanks.