Rotating a line?


#1

I get how to rotate shapes using the Command key and getting the rotate handle. Is there a way to do that for lines without using the spinner? That works but it is easier to just grab and spin in place like the shapes.


#2

There is a gesture for your trackpad. It’s a 2 finger rotate gesture. Search for “Multi-Touch” in OmniGraffle help for an overview with pictures.


#3

I see where the setting it but searching the manual and the on-line help only points out the option. I don’t see anything on ‘how to’ use it. I either get the object to move or a context menu instead of rotation. I am missing something…


#4

This is from the OmniGraffle 7 User Manual under Moving Objects:

To rotate an object, Command-drag one of its selection handles; you can also hold Shift to restrict the rotation to 15-degree increments.

If you’re using a Mac with a touch-sensitive trackpad, you can use the rotate gesture with two fingers to rotate the selected objects (be sure that Multi-Touch gestures are enabled in OmniGraffle ▸ Preferences ▸ Multi-Touch.

Hope that helps!


#5

I got the “Command” and drag for objects and a mouse or stylus. Holding down the “Shift” key is something new.

Okay, I have the preference set on the MultiTouch settings page. But still don’t know how. I have tried pressing down with two fingers; just dragging two fingers, click on a end node and use two fingers (both pressing down and just dragging) but don’t know how it works. Is there a video available on the OmniGroup site? I checked on the Tool and Style Well and the Object Inspector videos but neither discussed rotating an object or line.

Why is it important? I want to have a line that is “X” length and be able to place it wherever I need. This may involve rotating the line. The only way I can get that to work now is to grab the end handles and approximate the length, which gets harder if the line is not vertical or horizontal.


#6

FWIW, “Command” does not seem to work when rotating a line. Object bounds seem to stay as end nodes instead of getting the double arrow arc for rotate.


#7

If it is a line that is not connected to other graphics, command does work for me to rotate. Are you trying to rotate a line that connects 2 graphics? Because in that case you need to move the graphics to rotate the line.

Is the line already connected to other graphics?


#8

No, the line is just a short line segment with two nodes: start and end. If you look at this screen shot:

Stack

Each of those lines with hatches are drawn as separate elements then grouped together. I draw the base line first, then draw the short line, duplicating, rotating, and moving into position for each of the hatches. There are no magnets or connectors enabled so I can move where I want it.
So I am trying to keep the hatch lines all the same length (and I have been pretty close just eye-balling it but… ;-)
No matter what key I hold down, all I ever get are the cross-hairs on the end nodes. Never get the double arrow arc to show it is rotating. Tried Command, Option, and Control and tried pairing each with the Shift key.


#9

If the lines are not attached on either side, you can use the Geometry inspector to specify the exact length and the dial inside of it to specify the exact rotation percentage, or you can use the 2 finger trackpad rotate gesture. If you they attached, you’ll know because with a line selected you’ll be unable to change the geometry in the Object Inspector.

For just one line, the key commands do not apply for rotation. Select the line, and gesture_rotate - Rotate an object. With an object selected, touch the trackpad with two fingers and then rotate. That should show you an icon like this on canvas:

. This will work as long as your lines aren’t connected on either side.

If this doesn’t clarify, please email us an example of a document where this is happening with a link to this post from Contact Omni under the Help menu. That will give you someone else explaining, in case the way I’ve described it isn’t making sense.

Thanks,
Lanette


#10

Okay. I think I found it. It had to be enabled in System Preferences -> Trackpad -> Rotate as well as in OmniGraffle. If either is not enabled, it doesn’t work. I didn’t have it set at the System level so got nothing.


#11

May I input a feature request to be able to rotate lines the same as all other objects (using “Command” on end node)? The two finger rotate works but does not give the precision I would like. Using the input box for the angle is extremely precise but you have to go from mouse/pen, select the box, input the number, see if that works, and try again.

Thanks.