Screen Update/Refresh Problems on iPad


#1

Anyone get this?

When working on the iPad, the contents of the screen doesn’t update unless you pinch/move the Canvas.

Let’s say you unhide a layer, or select elements…these changes don’t show on the screen.

Once you move the Canvas, it redraws the elements and things show up.

This non-refresh becomes particularly problematic when trying to drag/move an element, it doesn’t show the position of the element until after you let go.

I rebooted the iPad and force quit OG, didn’t seem to help!

iPad Pro 12.9"


#2

I have exactly the same problem. Have you solved it?


#3

See item #3 in this post from Ken Case:


#4

Can you please check that you have the latest version of OmniGraffle? You can choose About OmniGraffle from the Gear Menu, and the version should show there. We solved a bug like this in our OmniGraffle 3.7 release. If you update OmniGraffle, the fix should be available now for free. Sorry for the difficulty.

If you are using a version newer than OmniGraffle 3.7 and still experiencing a problem, can you please send us a document with steps to reproduce the issue, including which version of iOS and which version of OmniGraffle you are using to omnigraffle-ios@omnigroup.com.

Thanks,
Lanette


#5

I am using versiion 3.8.1 with the new 12.9” iPad and there are no steps needed to recreate as it happens all over the place immediately. Specifically the problems I’m facing are:

  • moving shapes with finger or pencil is not visible but smart guides do respond, this is the only indication of where the shape has gotten to!
  • after de-selecting a shape by clicking on blank part of the canvas, the right-hand context menu indicated that selection has been de-selected (aka, nothing is selected) but the corner handles remain indicating that the prior shape(s) are still selected
  • Choosing a new stroke color for a shape updates the property but it is not VISIBLY changed until you do something dramatic like switch to a different canvas and then come back.
  • If I draw out a rectangular selection, it is completely inaccurate and often selects items outside my selection range and whatever it selects you CAN’T see the selection boundaries. Only after dragging items do you find out after the fact what was selected.

I love OG but I am shocked at how these epic problems made it throught QC.


#6

Bizarre, I tried OG again today and it suddenly was working perfectly. Sadly that lasted about 10 minutes and then went back to the old mode.


#7

I’m running on a 2018 12.9 iPad Pro with iOS 12.1 using the new pencil with OG 3.8.1 Pro.

I’m finding it’s running painfully slow. Copy/pastes are taking 15-20 seconds which could be the screen refresh. Also can’t multiselect like I used to on older iPads since the contextual menu shows up and won’t disappear. Restarting the app helps only for a few minutes.

I’m going to do the uninstall/reinstall/restart iPad and see what happens. Glad to know it’s not just me.

Addendum

After trying many things it is indeed a screen refresh issue. Copy and paste is working but you just have to wait 10’s of seconds to see the result. Zooming in or out forces the screen to refresh and the changes will be shown.


#8

Thank you, everyone who shared reports of this problem and I’m sorry for this trouble. We have now reproduced this bug in house and it has been reported to the engineering team.

For now, the workarounds are to adjust the zoom level, or to close/reopen the document after using paste. The issue seems to be a problem with the selection highlight state after using copy/paste or duplicate.

Thanks,
Lanette


#9

thanks Lanette!


#10

V3.9 fixes this problem. Thank OmniFolks!