Scroll bars default to visible when using a mouse? [Yes: helps performance.]


I’ve found a bug that was introduced in one of the recent versions of OF2:

OSX Mavericks displays white scroll bars when a mouse is connected. In case you just use a touchpad it doesn’t display any scrollbars and scrolling looks like on iOS.

When a mouse is connected, this white scrollbar should only appear if the list is long enough that you actually have to scroll (this is the standard behavior in Mavericks and also how all the apps work). This was also the case in previous OF2 versions (I don’t know exactly in which version this was changed). In the current version these scroll bars are always displayed even though there is no need for them.

This is an intentional change.

You’ll notice that if you are using a standard mouse (or have changed the “Show scroll bars” setting to “Always” on the General system preferences) that TextEdit also always displays a vertical scroll bar on the right edge of the window.

In practice, auto-hiding vertical scroll bars is very problematic for complex views. Whenever scroll bars automatically hide or show, there is a lot of oscillation as things re-layout to accommodate the shrinking width, which can then cause the internal height of the view to change, which affects the scroll position, which might cause it to auto-hide again…

For performance reasons, if you have legacy scrollers enabled, OmniFocus will never auto-hide the scrollbar.


Thanks, got it!

I use a mouse most of the time, but since my mouse has a scroll wheel I don’t need my scrollbars to be visible all the time (as I would if I needed to click on them to drag them to a different position). So… in System Preferences, I’ve turned off scrollbars except while scrolling:

This means that OmniFocus (and all my other apps) have the same clean look whether I’m using a touchpad or a mouse.