"Send to Inbox" service from Mail doesn't work

I am trying the OmniFocus 2 public test, but am having trouble getting the “Send to Inbox” service to work.

I understand that this needs the plugin from OmniFocus 1. I have that installed, and it works fine. But, when I choose the “OmniFocus 2: Send to Inbox” service, nothing happens.

Has anyone else experienced this behaviour?

There’s a new way of doing this in OF2. see:


Technically, Mail Drop has been around since OF1. It was not introduced with OF2.

Thanks for your responses. I understand that Mail Drop is an alternative to the Mail plug-in, and that there may be a long-term plan to deprecate the plug-in in favour of Mail Drop. I have tried it, and it works, and I would be happy to switch to this in the long term.

However, I don’t want to switch to Mail Drop at this stage because it doesn’t replicate all of the functionality offered by the Mail plug-in. In particular, it doesn’t provide a link back to the original email from within OmniFocus.

My understanding was that the plug-in is still intended to work with OmniFocus 2. My confusion is that it doesn’t work for me, and my post was intended to ask whether anyone had any insights regarding why that might be.

good catch, I didn’t realize that Mail Drop didn’t include the link to the original email. Wish there was a way to do that, too, but in most cases I clip it anyway. Only use this technique when I’m on another device where I can’t clip.

i tried to clip (using the clip-o-tron plugin) from a movie newsletter this morning and it took an age. at first i thought it was a bug, and a freeze, it took so long i forced quit. eventually after trying again i realised that the long delay was because it was a graphics rich html newsletter i was trying to clip, and took a very long time, putting lots of strain on processing power i guess.

perhaps there could be an option with the clipping service to ‘send linkback to omnifocus inbox’ with just the subject line of the email?

Make sure OF2 is running before you clip - does it make a difference?

Thanks for all the helpful responses.

It’s now begun working. I haven’t managed to work out what I’m doing differently, or what I did to get it started: I tried various combinations of removing and reinstalling the plug-in, quitting and restarting Mail and OmniFocus, and rebooting the machine. I thought I’d checked that none of them worked, but perhaps one of them did.

@Nick: It seems to work much better if OF2 is already running before clipping. Using the service will launch OF2 if it isn’t running, but then it seems to get confused.

@kened: I also think the linkback option would be good. I use this service as a way of managing my email inbox, so being able to get back to the original is important - but having a copy of the email in the OF2 notes field is not so much.