Shapes created with fixed height

I believe I may have unknowingly set some configuration for the shape tool which is making it less than fully usable. I’ve tried reseting preferences in the preferences menu, though this doesn’t seem to have changed the behavior. Any help would be most appreciated.

When using the shape tool, new shapes seem to be created with a fixed height. Moving the cursor vertically while creating the shape only repositions the shape, without altering its height. Additionally, new shapes only have two resizing handles, on their left and right sides:

Increasing the height of the shape in the geometry area of the object inspector after it has been created seems to restore the shape to normal conditions — it has all eight resizing handles, and can be freely resized to any height.

The issue is persistent for all shape types and document templates that I’ve tried, and as I mentioned, is not resolved by reseting tool settings in the preferences menu.

If anyone’s encountered this before or has any idea for something to try to change this behavior, please let me know. Thanks in advance for any advice.

I have just run into the same issue - was there a resolution ever found?

Ok - I called Omnigroup support and we were able to get it fixed (Yeah! Thanks!).

Essentially my canvas got locked into some sort of line tool, which meant I was creating shapes that could only be modified by width.

The answer to fix is:

  1. Copy a stencil over
  2. Click on the shapes tool
  3. Select the tool dropdown, and you should see the lines across (Omnigroup support guy called it a line…something, can’t remember) - Then look under canvas styles and select a normal type shape. From then on, the shape tool should work better.