Shared Workflows & Updated Scripts

Hi there,

I’ve written, tweaked, updated & borrowed and number of scripts to create a workflow for editing pdf text once I’ve imported them into OmniOutliner via text file. Plus some are just super handy to regular outlining.

This involves script to do the following (Listed in order of use):

  • Merge 2 columns into a third (delete the original columns and repeat until only 2 columns remain at which point the next script is used)
  • Copy Column b to topic column (Gets around not being able to change the topic column)
  • Merge rows (including when the rows are nested)
  • Removing empty rows and empty space both before and after text in a row
  • Remove Symbols at the start of a row ( new symbols can be added easily ( ,"%")

It’s taken me a hell of a long time to get these scripts together as I’ve been learning Applescript from scratch for this & that’s even with the large bulk of the code coming from others including regulars to these forums but it’s been worth it, They save a hell of a lot of time.

When I get a moment I’ll try and track down when I got the core of the scripts from and credit the past authers properly.

I’ve uploaded the scripts to github at the following address:

Might be nice if anyone else with script workflows also posted & we could build up a more up to date script resource/Library than is currently available.

PS: I requested a whole bunch of these features in the upcoming update of OmniOutliner too…

1 Like

Does anyone have an idea why the following script (that used to work in v.4) no longer selects empty rows in an outline of just one column?
tell application id "OOut" to select (rows of front document where topic = "" and note = "")

I just tried out your script and it worked perfectly for me in OO4 as it is… not sure what your issue may be.

1 Like

Well, then! I just tried it on another of my outlines (had been living in just one for a couple of days) and it worked. Tried it in the old one, and it worked there as well.

I am not even sure I rebooted or anything. Certainly no system updates, app updates, etc. Chalk it up to user error.