Shortcut leads to constant crashing

I finally decided to give OF3 a try as I began to realize that I have outgrown 2Do, which has been my task management app for many years now. Today I downloaded the app, subscribed to the trial, and dove into learning how OF3 works. I got to the point where I decided to modify an existing Shortcut for 2Do to work with OF3. It basically takes a set of data that I do at various times of the year, parses the data into individual tasks, and then fills the data into the fields of the “Add Item” OF3 module in Shortcuts for each task. Pretty straightforward. I also have an alert at the end that identifies how many tasks were created and the time frame for due dates. Finally, the shortcut ends by opening the specific project in OF3.

The problem is that when it got to the last part of opening OF3, OmniFocus crashed. Now I can’t get it to open. I even did a hard reset of my iPad, and it crashes on opening every time. Any thoughts about this? Is this a known bug? Is it related to the Shortcut itself, or did my iPad just simply go nuts?

Edited to add: I deleted the app and reinstalled. All seemed to work fine. I tried running the Shortcut again, and the same problem occurred. The funny part is that in the multitasking view of iOS, I can see that the new tasks are all in the project. So the shortcut worked. But the app insisted on crashing every time I try to opened. Finally, I removed the last action in the shortcut: “Show [Project] in OmniFocus”. That solved the problem, but is that a known bug? I wouldn’t think that including that action would create such a catastrophic reaction.