Snap to grid doesn't snap to grid


#1

I’ve turned on the option for Snap to Grid, but nothing snaps to the grid. How do I turn on Snap to Grid so that it snaps to the grid?


#2

It’s likely that there might not be any perceptible snapping due to a combination of your current zoom level and the Major/Minor Grid settings. What settings are you currently using in the Canvas:Grid Inspector?

You may want to try increasing the Major Grid Spacing and decreasing the Minor Grid Steps in order to see a more noticeable snap when reorienting objects on your canvas. More information about the settings in this inspector can be found in the OmniGraffle user manual here.

If you’re still having trouble getting objects to snap to your grid, please email us the document you’re having trouble with at omnigraffle@omnigroup.com so we can offer further suggestions. Thank you!


#3

I also can’t snap to grid. Even with great big settings like this:

I drag the boxes around, and they land on any pixel. Do I misunderstand?
(I finally just today upgraded from OG4 to OG7 but I think it used to be simple?)


#4

It may be because you are enforcing automatic layout for all objects. Under Diagram Style and Layout, change the dropdown to include connected objects instead of all objects. That way you control placement of your graphics that aren’t connected instead of the Diagram Layout settings.

This hasn’t changed from the earlier versions, but we did add the option to only include connected objects for Automatic Layout.

If that doesn’t solve the problem, you might be experiencing and issue that we aren’t seeing here. Please reach out to us from Contact Omni under the help menu.

Thanks,

Lanette