Spotlight in High Sierra doesn't show results from OF

I’m currently beta testing macOS 10.13 High Sierra.
I just discovered that spotlight doesn’t show any results from OmniFocus. Search within OF works though.

Is this something I should report to Apple or OmniGroup?

I have rebuilt the Spotlight Index.


1 Like

I had the identical problem with OmniOutliner on iOS. It ws solved by doing a cold restart.
Signed, Certified Microsoft Rebooter from the 1990’s.

I would report it to both.

When reporting to Omni, bear in mind that, because HS is in beta, they can’t guarantee a fix - but they will not the issue and get it resolved if at all possible by the time HS is released (based on my past experience.

I have this issue using the non-beta macOS High Sierra 10.13
Spotlight does not find any Omnifocus tasks

I still have this issue as well…

Any news on this yet? It’s a PITA to not be able to Spotlight OF content… :(

(FWIW I have rebuilt the index and changed computer (with new OS etc) since I created this thread)

Did you ever get a resolution on this? I just upgraded straight from regular Sierra to Mojave and the lack of ofocus-project-metadata files flat out breaks my workflow. (I use the metadata files to apply Finder tags to projects in OF2.)

No solution. I have to search separately in OF, which is a PITA. 🙁

AFAIK Omni are aware of this, I don’t know what’s the problem though.

Apologies for jumping in late. Has anyone opened a ticket on this? If not I volunteer.

@carlsson Ugh, that is disappointing to read. Looking at the structure of the metadata file, I’m going to try writing an AppleScript to create the files and see if that meets my needs. I don’t think creating the files will be an issue, but keeping them updated won’t be easy.

@tlillis4 Be my guest. I haven’t done anything yet, still getting my system back to 100% after a full nuke & pave, was going to do more research and/or bug reporting over the weekend.

I have filed a bug report to Omni at two occasions.
But please write more and we may get this thing fixed.

I’ve opened a ticket [OG #2233085] I’m willing to spend time on this so perhaps we can get a solution. Ironically, I’ve created on OmniFocus project for it so it won’t fall between the cracks. 😀

I reached out to the Support Humans and here’s the fix that worked for me.

First, does ~/Library/Caches/Metadata folder exist?

If yes, then you have a different issue than I did, sorry.
If no, follow steps below:

  1. Close OF
  2. Manually create “Metadata” folder in ~/Library/Caches
  3. Relaunch OF

Expected behavior: com.omnigroup.OmniFocus2 (or 3) should be created and populated with the focus-project-metadata files almost instantaneously.

Point of curiosity if this fixes it for you, did you do an upgrade install or clean install of your current OS?


That fixed the problem for me as well. About the same time you posted I received an email from Support Human Bethany F.

I’ll write up my use case later in the month for those who are interested and post it in a new thread.

Some notes for your write up (props to you for doing that! I get 90% of my computer fixes because someone in the past documented their problem and fix), should you want them:

I did a clean install of Mojave, it looks like Safari doesn’t utilize ~/Library/Caches/Metadata anymore so the folder is not created with a clean install. I’m guessing an upgrade install would preserve the folder and OF wouldn’t know the difference.

I also took a rare path (according to OF support) to transfer my OF database, I just copy the file to the appropriate Containers subfolder. OF support said they expect most users launch OF and then pull the database from the server.

Tagging @carlsson, I really hope this fix works for you too!

Thanks for the input Aeryn. Nothing of this helps me though.

I have done clean installs as well as updates during the last 2-4 years, as well as different computers. To no avail.

I do have the Metadata folder at my current setup. It contains two folders;
• CoreSpotlight

My current setup is an old MacBook Air, because my 2017 MBP is having its keyboard replaced. When I installed this MBA (3 weeks ago) I had to install the latest OF, and at that time it also asked me to login to my cloud storage. This makes me believe that OF is missing something – Otherwise Spotligt search should have worked by now.

Just to clarify my error I have attached a picture showing a Spotligth search, and as you can see, the OF result is not included.