Stuck Today Extension? Here's how to unstick while we work on fixing the underlying bug

Since 2.1 we’ve had scattered reports of the OmniFocus Today Extension getting stuck, and with 2.2 adding more options to the Extension it’s likely that more folks will start to experience the problem (we’re still working on a fix).

While we try to squash the behavior, these steps should work to reset a stuck OmniFocus Today Extension:

  1. Launch Applications > Utilities > Activity Monitor
  2. Switch to the CPU tab
  3. Search for OmniFocus; there should be two entries
  4. One has an OmniFocus icon, and the other has a generic plug-in icon (you may need to trigger Today in the sidebar, to get the second icon to show). Select the one with the plug-in icon.
  5. Select the menu View > Quit Process…, and click Force Quit.

When you next show Today, the extension should refresh with accurate information. In many cases (though not all), the fix endures.


After upgrading to 2.2, I also had to quit and re-launch OmniFocus to get the Today extension to refresh.

Unfortunately this didn’t work for me – I killed the OmniFocus plugin process, then quit and restarted OmniFocus (per @bps’s suggestion), but no dice.

What finally worked for me was killing the entire Notification Center process.

If you have a stuck Today view and you’re thinking of trying this yourself, be careful – make sure you don’t need anything currently open in Notification Center before you Force Quit it. You may lose outstanding notifications or changes to your Today widgets.

Ultimately, I had to:

  1. Quit OmniFocus
  2. Force-Quit the “Notification Center” process
  3. Restart OmniFocus
  4. After a few seconds, my Today view refreshed correctly.

Yes, same for me. It didn’t refresh until I quit/restarted OF.

any chance we get a quick hot fix for this?

Weirdly, this morning (after a reset of my Mac) Today was displaying the same list of “stuck” tasks some of which had been completed. Thankfully it refreshed itself after about 30 seconds but it was strange that Today had reverted to it’s previous stuck state including old tasks.

[bump] Worked for me. Thank you.