Sync preferences aren't sticking [A: check keychain for dupes.]

I have OF2 from the MAS, and I set the omni sync server address and choose to replace database. This works, and I can continue to sync with the omnisync server until I quit the program. Once I reopen it, I attempt to click ‘sync’ and rather than sync, it just says that I need to re-setup the omnisync services.

I’m guessing this is a bug… But, it’s quite annoying. Can anyone confirm?

That is definitely an annoying bug.
It’s probably going to be hard to diagnose over these forums, so please also email

That said, I’ll try to make a wild guess: is there any chance you’ve got more than one copy of OmniFocus lurking in your Applications folder? Maybe a trial copy downloaded from our site, or a test build from a couple weeks ago? They have separate preferences, so setting up sync in one and then launching the other could cause this sort of misbehavior.

I’m having the same issue, and I only have the one copy of OF2. None of my preferences are saving.

I posted this in another message about the same issue.

I had the same issue and emailed OmniGroup support. They emailed me a simple fix - rebooting my machine. I’m not sure why that fixed it, but my sync preferences are saving now.

Thanks, the reboot worked. Don’t care why, just thankful it was that easy to fix. All prefs now save. Thanks for your answer.

I tried rebooting but I am still getting the prompt for login details whenever it syncs (using OmniSync).
So if anyone has tried other solution, I would love to hear about them.


Just got almost immediate response from support. This solution did the trick:

  1. Quit OmniFocus.
  2. In the “Utilities” folder on your Mac, launch the “Keychain Access” app.
  3. Enter “omnigroup” in the search field in the upper right of the Keychain Access window.
  4. Click the header of the “Name” column at the left of the window to sort the results alphabetically.
  5. Scroll down to the entries that start with “sync” (in some cases, you’ll see something like “sync3” or some other number; that counts too.)

Delete all the entries, then quit Keychain access. Tell OmniFocus to sync, enter the login information one last time, and you should be up and running.

1 Like

Hey guys. I’m a new Omnifocus user, and while I love the app, this one thing is driving me nuts.

No matter how many times I enter my credentials into the sync dialog, it keeps popping up. The dialog is the one that says “The Server ‘Omni Sync’ requires authentication”. I enter the correct credentials, and then sync even works, but it still keeps asking me.

I do have “Remember in Keychain” checked as well.

Please guys, what’s the solution?

There are a couple of other threads on this issue.

Here’s one possible solution:

Also, if you clip stuff to OF using Services, make sure OF is running first. More in this post:

1 Like

I moved 2 posts to an existing topic: Sync options aren’t sticking in prefs

I’m having the same issue on two different computers. Kind of makes the product unusable. We need a fix fast.

I moved 3 posts to an existing topic: Sync preferences aren’t sticking [A: check keychain for dupes.]

I moved a post to an existing topic: Sync preferences aren’t sticking [A: check keychain for dupes.]

This topic is now invisible. It will no longer be displayed in any topic lists. The only way to access this topic is via direct link.

I am a brand new user and was pulling my hair out with this “The Server ‘Omni Sync’ requires authentication”. For me I discovered the problem and the solution as follows, thanks to my use of an additional automated login system other than key chain.

When I registered my user name it had capitals in it. Apparently and most bizarrely the Omni focus registration system converts all capitals in your user name to lower case and makes the use of lower case mandatory. Very helpfully, it does not tell you this and Key Chain and similar products record the User Name as you entered it, rather than as Omni Focus decided to change it to, i.e all lower case, and make case sensitive.

Having changed my User Name to all lower case I no longer have an issue with “The Server ‘Omni Sync’ requires authentication”. The fault is not with Key Chain or sandboxing as far as I can tell, it appears to be in Omni Focus itself.