Syncing OmniPresence to nginx


#1

I am trying to get OmniPresence to work with nginx. I can’t see anywhere that the Nginx fix for OmniFocus has been added to OmniPresence. Can we expect that to be added at some point?

Thanks!


Setting up a private OmniFocus Sync Server With NGINX on Ubuntu
#2

Hi @kingbird! I’m sorry to hear you’re having trouble with nginx and OmniPresence. However, there are several differences between OmniFocus and OmniPresence in how they communicate with WebDAV servers, so it’s not necessarily the case that a fix for OmniFocus applies the same to OmniPresence, or vice versa.

Is there a particular error that you’re encountering? We can’t always help with custom server configurations, but it’s possible that someone else on the forums has a similar nginx setup and might know a workaround.


#3

Hi @tekl . Thanks for your reply.

I am receiving the following error in omnipresence:

We could not connect to your selected cloud location.

Could not access the WebDAV location <https://***/webdav/OmniDAV-Conformance-Tests-fxEFN0RQuap/fortestReplacedCollectionUpdatesModificationDate:-/parent/tmp/doc>.

Please make sure that the destination folder exists.

And in Console, the following:

Error validating account: {
    code = 409;
    domain = "com.omnigroup.frameworks.OmniDAV.DAVHTTP.ErrorDomain";
    userInfo =     {
        NSLocalizedDescription = "Could not access the WebDAV location <https://***/webdav/OmniDAV-Conformance-Tests-fxEFN0RQuap/fortestReplacedCollectionUpdatesModificationDate:-/parent/tmp/doc>.";
        NSLocalizedRecoverySuggestion = "Please make sure that the destination folder exists.";
        NSUnderlyingError =         {
            code = 409;
            domain = "com.omnigroup.frameworks.OmniDAV.DAVHTTP.ErrorDomain";
            userInfo =             {
                NSErrorFailingURLKey = "https://***/webdav/OmniDAV-Conformance-Tests-fxEFN0RQuap/fortestReplacedCollectionUpdatesModificationDate:-/parent/tmp/doc";
                NSLocalizedDescription = "Unable to perform WebDAV operation.";
                NSLocalizedRecoverySuggestion = "The *** server returned \U201cconflict\U201d (409) in response to a request to \U201cMOVE /webdav/OmniDAV-Confor

I have a standard NGINX setup (v. 1.10.3) with the “extras” plugins package, i.e.:

location /webdav {
		root /***;
		client_body_temp_path /***;
		dav_methods PUT DELETE MKCOL COPY MOVE;
		dav_ext_methods PROPFIND OPTIONS;
		create_full_put_path on;
		dav_access user:rw group:rw all:rw;
		autoindex on;
		auth_basic "restricted";
		auth_basic_user_file /***;
	}

#4

This seems to be a similar issue: https://github.com/owncloud/core/issues/13228


#5

I posted about the same issue here:

I do believe that https://github.com/owncloud/core/issues/8033 covers what the issue is. I hope there’s a way to fix this on the OmniPresence side, as I’d love to run my own server – OmniPresence is a great, simple solution to my own cloud storage, but I’d like to not run Apache just to run it.