Tasks assigned to project do not appear under project

I’m doing something wrong here, hopefully someone can quickly point it out because it is driving me nuts.

In the gif below, I have an inbox action that I’ve added to a project, but it doesn’t show up under the project.

I’ve experienced sort of hit-or-miss functionality like this several times when creating a task and assigning it to a new project created with the same dialog. (Type new project name into task creation dialog, click “create … project”).

Any advice is appreciated.



In Preferences -> Organization, what is your setting for Clean up inbox items which have:?

@khaberz thanks for replying. That setting is currently set to “Both a Project and a Context”.

I admit I have absolutely no idea what that is for…I tried several states and wasn’t able to discern a difference, but I’ve only been using the software for a couple days now.

The task you have in your screenshot has a project assigned, but not a context. Based on setting Both… , it will remain in your inbox until you assign it a context too.
If you change the setting to A Project or Either a Project or a context, it should also move to the Project (click clean up in the toolbar to get it out of the Inbox right away)

Okay, thanks for clarifying that.

As a bit of follow up…when I change that setting to A Context only, several of the project-less tasks that have contexts are forced into an automatically created project called “Miscellaneous”. Is that normal?

Further, when I change the setting back to A Project, why don’t the items which are project less return to the inbox?

A further point of clarification: is it possible to manually move items from or to the inbox?

It seems silly that, even though I’ve assigned the task to the project, it doesn’t appear under the project because it is still in the inbox.


Yes, Omnifocus considers a task without a project unprocessed. Therefore it assigns it this generic project. Consider it the project for non-project tasks :-)
I just tried to reproduce this here, and I have one existing project set as the default project that is used instead of your Miscellaneous. I know this was a preference setting in Omifocus1, but I can’t find it on OF2 right now. Maybe the setting is gone and mine got grandfathered from OF1. Maybe one of the OF staff can speak to this?

Because at that point they technically belong to a project - Miscellaneous in your case

If by “manually”, you mean drag&drop, this is currently only possible by opening a second OF window. There are extensive discussions about this topic in this forum. I assume this will be changed in some way down the road.
Personally, I am fine with using the keyboard only for assigning projects and contexts, I find it faster, and the predictive dropdown when typing projects and contexts are really good. Note also, that you can assign multiple tasks to a project at once by marking them first and then changing the project in inspector.