Theme: "newantiglarecolortext"


#1

I call it newantiglarecolortext! I am not keen on white screen!

https://www.dropbox.com/s/a1g9xwdlw7m92qp/newantiglarecolortext.ofocus-style?dl=0

or here;
https://drive.google.com/open?id=0B0lHTAc6LsoISGJXU09MMVY3VzA


The Theme-Sharing Thread
The Theme-Sharing Thread
#2

I look forward to trying it out. I got an error when I tried to import it into OF.

Unable to Validate Contents of Style File
Invalid Font Collection Property List: Font name missing from description of text style “OFITextStyleCustomizedSidebarTabTitle”.

This is an unrecoverable problem. This style cannot be used.


#3

@teronel try the google link. I’ve tried it and it works.


#4

I clicked the link, which opened the google drive file in my browser, then I used the google download button. I then attempted to import that into OF. No go the first time around. I tried it again just now with the same results. I also just tried using the dropbox link. Same thing.


#5

open the google link use the downward arrow and you should get the OF style folder-I just re-tried that and it worked.


#6

I’m using MacOS 10.11.6 El Capitan. Perhaps the new styling only works in Mac OS Sierra. I’m waiting for FIleMaker 15 to finally gain complete compatibility with MacOS 10.12 Sierra. That’s why I haven’t upgraded to 10.12.

So perhaps it is the MacOS that’s causing this funky message?


#7

Maybe. I’m running Sierra v10.12.


#8

Ahh… maybe that’s it. I’ll have to wait until I can upgrade to Sierra. I’m also updating to the newest public test release of OmniFocus 2.

It seems to be related to a System font issue of some sort.

I guess I’ll just wait. FileMaker is critical for me. I can’t upgrade to Sierra just yet. Thanks!


#9

I’m also still on El Capitan. (Limping along on a 2010 Macbook Air.) Will check out the theme when I can upgrade. Thanks, @wilsonng and @revstu .


#10

I get the same error on Sierra 10.12.1 – was not able to import, downloaded via google link


#11

Sounds like @revstu might be using a font others don’t have. Maybe sub in a system (or standard Mac-included) font, re-save, and re-upload?

Just a thought, but I’m guessing.

ScottyJ


#12

Sorry folks I can’t be more of a help. I think I’m using standard SF font though I do have alternative fonts i dont think this theme is using them.


#13

Our apologies for the trouble! Changes were made to OmniFocus 2.8, in order to support the new macOS Sierra tabs. In the process, the .ofocus-style format gained additional information, and files created with older versions of OmniFocus 2 or OmniFocusColors will either present a warning, or fail to open.

We’ve just published OmniFocusColors 0.9, which fixes both recoverable and non-recoverable errors. If you open and save an existing .ofocus-style file, it should open in OmniFocus 2.8 (currently in public test) without any further problems.

We’ve checked it against every theme in this thread (thus far!), all of which will happily open in OmniFocus 2.8, after being re-saved.

Hope that gets everybody back up and running; thank you for using OmniFocus, and for the wonderful themes!


#14

Thanks @orion.

Selecting a style in the Preferences worked. But if I tried to choose the font collection, it comes up with:

Error applying font collection:
Invalid Font Collection Property List

This is an unrecoverable problem. This style cannot be used.

It looks like part of it is solved. This was with @revstu’s new antiglarecolortext theme. I haven’t tried the other themes yet. I opened the theme file and re-saved it before importing it into OmniFocus.


#15

Hmmm… sorry about that!

Just to verify, you:

  1. Downloaded the current version (since I saw he’s just updated it).
  2. Opened it in OmniFocusColors 0.9, and then saved it.
  3. Opened it in OmniFocus 2.8.
  4. Chose the colourfont color palette, which worked.
  5. Chose a different font (which one?), and then saw the error?

Walking those steps with OmniFocus 2.8 r276083 (the latest build, as of this post), it works. But… I’m also on Sierra, so that’s likely to be the difference.

Update: I just checked on 10.11.6, and it appears to be working the same way there… so I’m missing something. If you can ping me with the difference in the approach you’re taking, I’m happy to try again!


#16

I downloaded most current theme.
Opened in OmniFocusColors 0.9
Went to OmniFocus preferences > Style
Clicked import style
Selected the style via popup menu: newanticolorglaretext

The problem arises when I try to change Font Collection to newanticolorglaretext

It displays the error message as seen in my previous reply. Otherwise, it imported and displayed fine.

I just left Font collection to System Font now.


#17

Thank you for the information; I’m still not seeing that error, but at least I have the correct file!

My steps:

  1. Open newantiglarecolortext.ofocus-style in OmniFocus 2.8; it fails, with the error we’d expect, at this point.
  2. Open it in OmniFocusColors 0.9, and immediately save it.
  3. Open that version of the .ofocus-style in OmniFocus 2.8, and it imports without error.

It is interesting to note that once I select Color palette: newantiglarecolortext, I am only offered three choices in Font collection:

  1. Promixa Nova
  2. Georgia
  3. System Font

It sounds as though you have an additional option listed, which isn’t showing up for me after conversion, under either Sierra or El Capitan. Looking at newantiglarecolortext.ofocus-style in BBEdit, it appears that the only font specified is the System Font. If that’s the case, then you might want to just click on Export Current Style..., which will allow OmniFocus to export a clean version of that file. You should then be able to re-import and use it, without further error.