"This database is already encrypted." error [2.19 / 2.9 and non-omni WebDAV host]

After update omnifocus for Mac to the latest, now it cannot sync. The error is “Unable to synchronize database with server. This database is already encrypted.”
It had been encrypted for a while (with webDav) and it synced fine, up until this moment.

1 Like

I solved it by remove all files on that WebDav server and resync every device manually.

Sorry to hear about this error! We didn’t encounter it at all during the (long) test period for 2.19 and 2.9, but it does look like at least one WebDAV host has a setup that is causing it in the wild. If you two haven’t already, can you email omnifocus@omnigroup.com with the details of your sync setup so we can figure out what to do to avoid it in the future? Thanks a ton.

I also encounter this problem. I have my own WebDAV, I installed OmniFocus on Mac, iPhone and iPad. And they all can not sync data with the error message of “This database is already encrypted.”. All Apps already upgraded to the latest version.

Please help to solve the problem.

At this point, I really hope OmniGroup can consider cloudkit or dropbox syncing.
Since every WebDAV host has its own idiosyncrasy, errors like this probably are bound to happen one way or another.

We’ve tracked down this WebDAV conformance issue and written up a support article which explains what the problem is and how WebDAV implementations can fix it:


(We hadn’t encountered this error until now because this release is the first time that OmniFocus has ever tried to overwrite a file on its sync server.)

Does this problem affect Apple’s own Server WebDAV? I’d like to know before upgrading to 2.9. Thanks.

I don’t think we’ve heard any reports of this issue with any Apache-based webdav servers (including Apple’s macOS Server). But I haven’t tested this myself.

This particular issue only affects upgrading a server database in place. I believe that people who are affected by this issue can work around it by removing their database from their server and then syncing a fresh copy. (That way OmniFocus won’t need to overwrite existing files, and thus won’t run into this server bug.)

Thanks. I just upgraded to 2.19 & 2.9 without any problems on Apple Server.

Yes, I resolve with the same way, replace what you have on the server side with local db