Transition from Things 3 to Omnifocus 4?

Are these the ones?

Yes, correct.

@albyrne For this (hopefully) fix I totally reworked the date handling. Covering Australian and German dates.

Unfortunately, it‘s not possible for me to test with your date setup.
Have a look at dates with only 1 digit as well as 2 for the day.

Good morning again @Logan . Yes, your most recent rework is functioning correctly on my (AU) configured MacBook Air. I have successfully tested with Things start and deadline dates with single digit (EG: 8 Mar 2024) and with two digits (EG: 26 Feb 2024). Not yet tested on iPad or iPhone.

I am very appreciative of your efforts. If support for transfers to OF4 at Things 3 project level may be incorporated in future, this will be very popular!

Thank you again.



@albyrne For you it‘s a good morning. For me it‘s now good night. Happy to hear v1.1.1 works. I have to think a little about how to approach the project topic without having to do again the action handling. I‘ll keep you updated.

1 Like

thumbs-up-vector copy

1 Like

Managed to process projects. But if I make a TaskPaper with a project and its corresponding tasks, then the tasks inherit all of the project‘s tags. Thus I have to create them separately and move the actions below the project (which is at that time an action, too). My first approach to do this failed.

Another issue is the more actions the Shortcut gets, the slower my iPad becomes when I perform changes to the actions and their variables.

I‘ll keep on building.

OMG! I do apologise for my question leading to this challenging work for you. You’re doing a very useful service to the T3/OF4 community.


Had to write to OmniGroup due to an issue with adding tasks via TaskPaper shortcut. I’ll keep on working on this.

Wow! I wasn’t expecting this. I’m no script writer or automator, but I do listen to David Sparks and Rosemary Orchard’s podcast ‘Automators’, so I’ve hearing positive things about Omnifocus Shortcuts support. I guess what you’re trying to achieve is maybe a little beyond what Omni envisaged!

Good luck, and, again, very many thanks for your efforts…


OmniFocus automation is quite powerful. The issue I have reported is quite simple. That’s why I did not know why is‘s behaving strange.

@albyrne Got a solution to move on. I’m going to move on tonight. Without that solution any tags set on Things 3 projects (e.g. Delegated) would be inherited to all of the projects actions in OF4.

So, when I use iPad with Apple Shortcuts and OF4 in split screen, then I can only create the first of two actions based on TaskPaper. In full screen that issue doesn‘t exist. Just reported that to OmniGroup. That explains why iPhone worked, but iPad didn‘t.

An ‘ah ha’ moment! I hope OmniGroup are appreciative of your bug reports…

@albyrne Just noticed a bug in the single action handling portion of the Apple Shorcut v1.1.1 . Due Date minutes were not handled properly. You probably got always 00.

I‘m currently working on project handling. For this I have to deal with the actions within the project as well. While updating variable naming to not get confused when reading the Shortcut between variables for single actions and project actions I found the issue. You‘ll probably get the fix tonight (12:50 here).

Any tags set on projects in Things 3 will just remain on projects in OF4. OK? Usually when assigning a project with a tag an action it automatically assigns the project‘s tag to the action as well. I‘d prevent the Shortcut from doing that. You have to tell me if you‘d like to get tags set on projects to all actions within the project as well.

@albyrne Please think about e.g. the „when“ date in Things 3. It just contains the date and you don‘t have any option to set a time. So it‘s always 00:00 (midnight). When transferred to OmniFocus, do you need an option to set a default time (like in OF by default)?

This should be the first version (v1.7) covering Things 3 tasks and projects with their tasks. Select them in Things 3 and run the Apple Shortcuts (no sharesheet used).

Enough for today.

Apologies for delayed response. It’s summer here, so this morning I’ve been at nearby beach, snorkelling with dolphins! Now back home and clearing my inbox…

I guess everyone’s use is different, but I am an old-school David Allen GTD disciple, so I use tags (in T3 or OF4) to indicate ‘context’ - assigning tags generally to actions only. I very rarely assign tags to a project. So, for my use, accurately transferring T3 tags to OF4 tags at ‘action’ level is most important.

I have just now tested OF4, and can confirm that if I enter just ‘00:00’ in a test action’s ‘defer’ field, the action appears as ‘available’ today. This tells me that OF4 is interpreting 00:00 as ‘beginning of day nn’, which is exactly as I would expect.

Given that I’ve had a few years of being quite comfortable with T3 ‘when’ dates being only available down to ‘day’ level, I’m quite happy if relevant T3 to-dos transfer to OF4 as actions with ‘defer’ of 00:00. In the rare cases in the future where I might want a more granular ‘defer’ (IE: down to hour or minute level), I can then set it as needed.

OK, downloaded v1.7 and tested on Mac.

No joy - the Shortcut is failing with a ‘…required app is missing’ message. From Shortcuts, clicking ‘View in App Store’, the missing app was ‘Logger for Shortcuts’. I figured that if the problematic step was just a logger, I could delete the step without negative impact, so I did so.

And, after approving some permissions as I run it, it now works!

The result I’m seeing in OF4 inbox is an ‘Action Group’, which I can easily convert to a project and move to appropriate folder. So far, I’ve tested only with a handful of simple test projects, but titles, tags, defer and due dates are all appearring correctly.

OF4 has no direct equivalent of T3’s project ‘headings’, so I didn’t expect them to import correctly. In OF4 I can workaround that issue quite easily by creating action groups.

The only glitch I have found so far is in text handling within project and task notes: double carriage returns are being converted to one carriage return. Where I have spaced paragraphs in notes by simply typing two returns, they are appearing as one return. Cosmetic problem only.


1 Like