Troubleshooting custom keyboard shortcuts that don't work [OmniFocus Clippings]

Instructions for Setting Up a Clippings Shortcut in OmniFocus 2 for Mac are in the manual. However, if you already tried setting it up and it’s not working here are some things you can try.

If a custom keyboard shortcut gives you a system ‘bonk’ sound but doesn’t show any conflicts in System Preferences ▸ Keyboard ▸ Shortcuts OR works sometimes but not other times, it may be conflicting with another third-party (non-Apple) app. If choosing [app menu] ▸ Services ▸ OmniFocus 2: Send to Inbox works but the keyboard shortcut doesn’t (or does sometimes but not other times) the problem is probably that another app is trying to use the same shortcut. So when that app isn’t running, OmniFocus can use it, but when the conflicting app is open, it ‘steals’ the shortcut.

It can be tricky to identify which app is causing a conflict. This Apple support article talks about how to identify when a third-party developer app shortcut conflicts with a system shortcut but it doesn’t always work to identify when two third-party apps conflict with each other. Here’re some steps that’ve worked for me:

  1. Quit every other app besides OmniFocus.
  2. Try the shortcut. If it works, open one other app and try the shortcut again.
  3. Repeat until it stops working.

The last app that was opened before it stops working is the one ‘stealing’ the shortcut from OmniFocus. Now quit OmniFocus and try the shortcut again and you should discover what the shortcut does in that other app. At that point you have two options:

Option 1:

Remap the other app’s command to a different shortcut in System Preferences ▸ Keyboard ▸ Shortcuts ▸ App Shortcuts which should allow OmniFocus to use it even when that app is running.

Option 2:

Pick a different shortcut for OmniFocus. I’ve had great success with Shift-Command-Comma (⇧⌘,).

And as always, if you’re still having trouble, we’re happy to help! Just email us!