Turn off auto-show notes with current action?

I’d like to turn off having the note for a current action automatically expanding when I click on the action in the day’s task list. I don’t think it worked this way pre-v4, but I can’t find a setting to turn it off. Any suggestions?


1 Like

OmniFocus 4 for Mac has an option to “Show note automatically” in Settings > Layout > Set Editing Fields. If you uncheck this option, the note field won’t appear automatically when you click on a task and can be manually shown and hidden by choosing View > Show/Hide Note (or by pressing ⌥⌘’).

This option exists in OmniFocus 4 for iPhone and iPad as well. Go to Settings > Layout > Set Editing Fields and turn off “Notes”. You can still access notes using the Inspector. If you have an iPad with an external keyboard, you can press ⌘’ to hide and show the note for the selected task.

I hope this helps!


Omnigroup being Omnigroup, I knew there had to be a way to do it. Thanks, Tim!


is there a way of doing this only in the forecast view - useful elsewhere

Yes, in Forecast (or any other perspective) you can customize those same options available if you’re using the Pro edition. Open View Options, scroll to the bottom, enable Custom row layout, then Set Editing Fields and you’ll find that Notes option.

Hope this helps!


Thanks Ken - yes have Pro. OF the one permanent app since I moved to Mac in 2012!

1 Like

I have deselected “Show notes automatically” but they continue to expand whenever I select a task with notes. Any thoughts on why this is happening or what I can do about it? Thanks!

Did you try hiding Notes from being displayed via (custom) Layout?

Thanks, @Logan. That was what I needed to do.