Turn off smart quotes?


#1

I give up, how do you turn off smart quotes in OmniGraffle 6?


#2

This drove me nuts for a good while too. Turns out a partial solution, at least for inches, is in System Preferences, but the solution was not obvious (poor OS X UX).

System Preferences… > Keyboard > Text

I thought having “Use smart quotes and dashes” unchecked would be a (OS X global) way to disable that, but it turns out you must use the pop up for Double Quotes (Single Quotes doesn’t work for me) to select non-smart quotes. UPDATE: this is working for Double Quotes, but not for Single Quotes. If you Undo after the non-smart single quote is transformed to a smart quote, it will revert to non-smart.


#3

it seems that OS X “Use smart quotes and dashes” off does no effect to OmniGraffle smart quotes behavior.


#4

It’s not a default setting, but you can type dumb quotes by using control-quote or control-shift-quote.


#5

That was also driving me nuts but after some hits and misses I found the solution.

omnibob almost had it!

System Preferences -> Keyboard -> Text
Use smart quotes and dashes: uncheck
for Double Quotes: select “abc” (last entry at the bottom)
for Single Quotes: select ‘abc’ (last entry at the bottom)

It seems that OmniGraffle assume the quotes replacement is always active.
So the trick here is to replace the standard quotes by the same quotes.

Setup: macOS Sierra 10.12.5 & OmniGraffle 7.4


#6

While editing text, you can control-click to access the contextual menu for substitutions where you can turn smart quotes on and off. OmniGraffle remembers your preference for that setting (across all documents) until you change it again using that contextual menu item.

(Sorry I didn’t notice this question sooner!)


#7

I totally overlooked contextual menus. Thanks for the solution, and as a reminder to right click when things don’t show up in (regular) menus.