Unable to open zip archive


#1

Hi all,

I have a very old iMac running OF1, and Macbook AIR running OF2. I deleted the database on the AIR and began again from scratch, replacing the db on the Omnisync server. After that, when I run OF1 on the iMac I get this odd message. Any ideas how to fix it? Thanks!

NOTE: I cannot upgrade to OF2 because my iMac is so old it can’t run anything beyond Yosemite. Just so you know.


#2

Hi @macronencer! Sorry for the trouble here.

For increased security and privacy, recent versions of OmniFocus 2 will encrypt your database on the sync server. OmniFocus 1 doesn’t support this encryption (since it was added well after OmniFocus 2’s release), and so doesn’t understand how to open your encrypted database.

If you’d like to start over with a fresh database, that’s definitely possible! Just do it using OmniFocus 1 from your iMac, instead of OmniFocus 2 on your MacBook Air. The newer copy of OmniFocus will notice that you’re using an older version elsewhere, and avoid encrypting your database in order to preserve compatibility.

Thanks for using OmniFocus!


#3

I just thought I’d note that if you do end up needing to start over (for compatibility with your old Mac), OmniFocus 2 can open both databases at once and transfer data from one database to the other (so you don’t have to reenter all your data).


#5

Thank you very much, tekl and kcase. That makes perfect sense now.

Fortunately, I’ve only added a handful of items to my inbox on the phone app, mainly because I was still unsure what would happen. I’m glad I was cautious!

I’ll start from scratch with OF1 this time. Eventually I plan to get a new iMac, at which point I’ll be able to install a more recent OS and run OF2.


#6

HI, I seem to have the same issue, but my setup is a bit different.

I have OF 1.10.6 running on two Macs (one ElCap, and one Sierra), and syncing w two iOS devices running OF 2.19.1. Although OF1 is buggy in Sierra, the Syncing has been working fine for years.

I synced all devices, moved old data to archive in ElCap, and synced all again, as I do every month. Both of my Macs are now displaying “Unable to open zip archive.” error, although seems to be working fine in iOS. (On one Mac, I tried reverting to a backup, but same when syncs w new dB on server.)

How can I move all data to a new dB, compatible w Mac v1. I could resort to yesterday’s backup on Mac… but is there a way to see recently modified items? Any other way to solve this issue… and how did this happen, I’ve not done anything out of the ordinary.

Thanks!