Unable to take Clippings from PDFs

Hi everyone,
I’m new to omni focus 2 and can’t figure this one thing out. Hopefully it is a simple fix. I’ve tried searching for a solution but can’t find one.

So I would like to take clippings from PDFs. I’ve setup my shortcut (which works well with word documents and safari), however it does not seem to work with PDF files. I’ve tried opening the PDFs in different apps (preview, adobe, evernote) and it still doesn’t work. When i go to the services section (e.g. preview>services) it just says “no services apply”. Whilst if i go to services when i am in safari a get a whole list of services.

Any advice would be greatly appreciated.

I think the clippings works best when you select text.

Here is the online manual with the section for clippings.


Your PDF needs to have text inside to be able to sending the text to OmniFocus clippings.

Or are you talking about embedding a PDF file into a task’s notes?

Yes, I am trying to clip the text from a PDF. I have highlighted it and pressed my shortcut and also tried going to services. However, none of these work…
So does it work with other people’s PDFs? have i forgotten to select something? seems to work fine with safari, and word documents.
I have uploaded a screenshot of what I am talking about.

I don’t know. It seems to work on my Mac Mini.

But I only have Mac OS X 10.11 El Capitan.

Thanks for the input.
Hmmm… I have Sierra… maybe an issue with Sierra? anyone else have this issue?

In Sierra, Apple changed PDFKit, the underlying structure to Preview and other apps that work with PDFs. I can’t explain it fully, but it’s wrecked some havoc with PDFs - for me related to ScanSnap scans and text recognition. I have held off updating until they fix it.

In any case, perhaps it’s related?

Here’s one link that might help explain more.

thanks for that. i also just found another discussion about sierra having problems with pdf services. quite annoying…

In my link (and their referenced link) it recommends “Smile’s PDFpen as an alternative for PDF manipulation of all sorts, with Adobe’s Acrobat DC being a more expensive option.”

Perhaps one of those work for you?

I’ve tried the Adobe Acrobat Reader DC and that doesn’t work either - maybe its a PDF wide thing??? i’ll give the smiles pdf pen a go tho.

I don’t know enough to comment further, but here’s the same author’s comments and recommendations on the update (10.12.4) released last week, in relation to PDF issues.