Updated OS X & Mail/Safari Clip-o-tron's gone. Can I reinstall? [A: Yes!]

Subject line says most of what I have to ask… I lost all mail services it looks like, so this may not be an omnifocus issue, per se.

Nonetheless, any help in the matter would be greatly appreciated. I can’t see any way of re-installing the clip-o-tron.


1 Like

The Clip-O-Tron is simply a patch for Mail which makes services available when you’ve selected a message (rather than requiring that you select some text inside the message before services become available).

Whenever it goes missing, you can just install it from OmniFocus 1 again. (We’ll also be providing a standalone Clip-O-Tron installer as a separate installer on our website so you won’t have to keep OmniFocus 1 around, but that’s not quite ready yet.)

1 Like

I have been using command-space-comma for my clippings shortcut for some time in OF1. When OF2 beta came out, I went into System Preference and set up the clippings shortcut, and it worked fine, up until a few days ago. My primary use is in Apple Mail. Now it is no longer working. I have reentered my shortcut via system preferences several time to no avail.

Any suggestions?


This isn’t working for me either, for Mail or Safari - I am using the latest build of OF2 for Mac. It was working OK with a previous build.


Broken for me too, as of latest System update. I reinstalled the Clip-o-Tron via OF 1 via instructions from another thread, but Safari clipping is still broken - the service is not available. Help?

Same problem, after installing 10.9.3. I will email the ninjas and suggest others do the same.

1 Like

To add to @kcase’s post: we can’t prevent Apple’s system updates from doing this from time to time, but they’re disabling all mail plugins automatically, not because they’ve actually detected any sort of problem.

Step 1 is to reinstall the clip-o-tron; step 2 is to restart Mail/Safari/other apps to make sure they pick up on the reinstalled clipper. If it’s still not working, email omnifocus@omnigroup.com and we can investigate/assist. Thanks!

Well, I’ve updated to 10.9.3. I’ve lost my Mail Clipping shortcut. I’ve selected Preferences in OmniFocus, General | Get Shortcut. The System Preference Pane | Keyboard | Shortcuts opened. I selected Services on the left. I scrolled down to Text section in the right hand pane. OmniFocus 2: Send to Inbox is selected with the same shortcut I’ve always used (CTRL-Option-Command-/ ). I’ve tried unchecking and rechecking the box. I’ve tried resetting the shortcut to the same keystrokes. I’ve restarted Mail.app after that.

All I’m getting is the unloving thunk that tells me nothing is happening when depressing the shortcut keys.

What am I missing?

Try reinstalling the Clip-o-Tron 3000 from OmniFocus 1 as described here:


The tool enables the Mail ‣ Services menu for when you have a message selected (vs. just selected text in a particular message). Hope that helps!


I was just drafting a post to record the same problem, so you are not alone, Troy.

I’ve worked around it with the following applescript and a hotkey implemented with keyboard maestro.

– Send currently selected Mail.app message to OmniFocus 2 quick entry box, then move it to the action folder for that account
– Archive behaviour found at: http://vemedio.com/blog/posts/my-archive-email-apple-script
tell application “Mail”
set theSelectedMessages to selection
set the selected_message to item 1 ¬
of the theSelectedMessages
set my_subject to the subject of the selected_message
set my_body to the content of the selected_message
set my_sender to the sender of the selected_message
set my_date to the date sent of the selected_message

set message_url to ¬
	"From: " & my_sender & return & ¬
	"Date: " & my_date & return & ¬
	"Subject: " & my_subject & return & return & ¬
	"message:<" & message id of selected_message & ">" & return & return & my_body

-- I move messages I've sent to OF to an 'action' mailbox (this makes them easier to
-- find on my iPad).  Uncomment these lines if you want to do the same thing
-- set _mb to mailbox of selected_message
-- set _acct to account of _mb

-- 	set _archive_box to _acct's mailbox "Action"

tell application "OmniFocus"
	tell quick entry
		make new inbox task with properties {name:my_subject, note:message_url}
	end tell
	-- tab into subject pane
	tell application "System Events"
		keystroke tab
	end tell
end tell

-- ditto comments above, the line below is related to moving messages I've sent to OF to an
-- 'action' folder.  Uncomment if you want this behavior
--	move selected_message to _archive_box

end tell

1 Like

Perfect! That worked. Hopefully this can be resolved for the next upgrade. Opening OF 1 and reenabling the Clip-O-Tron 3000 did the trick.

Thanks so much. My beloved shortcut is back again.

1 Like

+1 - please don’t consider OF 2 “done” until this functionality is installable from there!


We’ll be providing a standalone installer for the Clip-O-Tron as a separate download on our website.

(That said, we consider this a bug in Mail and hope you do too! Since it’s possible to Copy with a message selected, you should also be able to apply a Service with a message selected. Please let Apple know you’d like to see Services enabled in Mail whenever a message is selected.)

1 Like

Is that installer available yet?
Thanks for all the hard work your team put into the launch!

Folks, I created a slightly modified version of fozziebear’s aforementioned Mail to Quick Entry AppleScript that I execute using a keyboard shortcut setup in FastScripts, see:

(* Creates an OmniFocus task of the currently selected Apple Mail message *)
tell application "Mail"
	set _msgs to selected messages of message viewer 0
	set _msg to first item of _msgs
	set _msgID to do shell script "/usr/bin/python -c 'import sys, urllib; print urllib.quote(sys.argv[1])' " & (message id of _msg)
	set _taskTitle to the subject of the _msg
	set _taskNote to ¬
		"From: " & sender of the _msg & return & ¬
		"Date: " & date sent of the _msg & return & ¬
		"Subject: " & _taskTitle & return & ¬
		"Message: message://%3C" & (_msgID) & "%3E" & return & return & ¬
		content of the _msg
end tell

tell application "OmniFocus"
	tell quick entry
		set _task to make new inbox task with properties {name:_taskTitle, note:_taskNote}
		tell application "System Events" to keystroke tab
	end tell
end tell

I hope you find it useful. Enjoy!

Earlier today, we posted the new downloadable Clip-o-tron installer. Check this support article for more info. Hope that helps!


It looks like I have a permissions issue.

I tried to find the .mailbundle in the Finder to change it, but the Services in System Prefs just brings up Omnifocus.app.

So sad. Much want. Wow.

Huh! I haven’t seen that happen before. It seems possible that Repair Permissions in Disk Utility might take care of that, but that’s really just a guess. (If it doesn’t fix the issue, contact omnifocus@omnigroup.com and we’ll be happy to investigate this with you!)