Voice Control not working?

I was intrigued by Ken’s blog announcement a few days ago about the Voice Control capabilities added in OF 3.13. Up to today I haven’t used Voice Control at all so I spent some time today looking into what it can do. Then I downloaded and installed the Default Menu Items from the Omni Voice Control Commands page. However, I can’t for the life of me get them to work.

Can somebody tell me what I might be doing wrong?

Matthew

Greetings! Perhaps there is a mixup on which version you are installing? On the page are two download links, one for OmniFocus 3.13 and one for OmniFocus 4. The version is used by the system to enable the commands. Try clearing the previously installed commands and re-installing the set associated with the version you are using. Please let us know here if it is working for you!

https://omni-automation.com/voice-control/omnifocus-menus.html

Thanks for the suggestion. I’m pretty sure I had installed the correct version. Just to be sure, I deleted all the commands and reinstalled the version for OF 3. Right now it looks like nothing is working again. I’ll try again later sometime after I restart my Mac.

AAMOF a few days I was playing around with Voice Control and OF again and at least some of the commends did work. But not all of them. Right now I can’t remember what worked and what didn’t. This is weird.

Let’s see if we can trouble shoot.

  1. Do the commands appear correctly in the commands list in the Voice Control system preference pane?
  2. What do you mean by don’t work? Are the commands recognized but nothing happens? Or are the commands not being recognized?
  3. What is the default language on your computer? The commands are currently posted for U.S. English and Canadian English.

have you tried any other commands aside from the default menu items? There’s over 90 specialized commands available in the collection. Do any of them work?

Thanks for your help, Sal.

Now after logging out and restarting the computer things have started working.

  1. The commands have always appeared correctly in the commands list.

  2. Before I restarted the commands were not being recognized. Now most of the commands I have tried in a five minute test session were recognized and correctly executed. Some of the commands are not recognized at all. If I recall correctly, a few of them sound like they were recognized but I couldn’t see that anything happened.

I’ll look into this more closely when I have the time.

  1. Default language is US English.