Waiting Perspective

I have a context called “waiting” where I put all the items that are on hold.

I would like to create a perspective which just pulls all tasks with context “waiting”.

Here’s I have it configured: https://www.dropbox.com/s/6tk1uwssr3vj606/Screenshot%202014-08-20%2010.58.58.png?dl=0

It shows me all the projects/items under “No Contexts” and then it shows me the “Waiting”.

How can I configure it to show me all tasks sorted by project with “Waiting” context?

1 Like

Here’s the way I’ve configured my Waiting perspective. The key is to switch to the Contexts perspective, select your “Waiting” context from the sidebar and then click “Add Current Sidebar Selection” under Sidebar Selection to add this selection to your Waiting perspective.

I hope this helps…


How did you get the Waiting show up in “Add Current Sidebar Selection” ?

It still lists all projects.

Change the Project Hierarchy setting to “Don’t use project hierarchy” and you’ll see contexts in the sidebar.


That worked! Thanks


You’re very welcome. Good to hear that did the trick…

1 Like

Instead of making a new thread, I thought I might continue this one. I made a Waiting Perspective, but there is one very annoying problem with it. If no actions have the Waiting context, all actions, regardless of what context they have, show up in the perspective. Is this a bug, or is there a workaround? Any ideas?

EDIT: Nevermind, I resolved it, made a dumb mistake: “Filter context: Active”

Sorry to bump - I have one question which is that when I do this (for a ‘morning coffee’ perspective), it includes items with no context. Is there a way to stop ‘no context’ from appearing in the list?

Did you read the first two posts in this thread?
As far as I can see that is exactly your problem and the answer to it.

I did, I promise - I think the thing that has thrown me is that it doesn’t act as a filter, but as a pre-selection - so all the active contexts are still shown, just de-selected. Can live with that, though it feels neater to be able to filter on specific contexts rather than just have them all shown and some selected.

Ah, sorry, I didn’t realize you where talking about the contexts being shown instead of tasks in those contexts. My apologies!

No, right now, there is nothing you can do to hide all other contexts. Maybe one thing you could try is changing the “Filter contexts” setting in your perspective to “On Hold”? That way, at least all the active contexts are hidden, but you can’t hide the ‘No Context’ that way…

This post is a THANK YOU!!! for the person who came up with the idea of a “waiting” context and perspective. I don’t remember if I learned about it from this thread, but it was definitely from this forum. Every time I use it, I am so grateful!!