WEBDAV on Synology [Fixed in DSM 5.2]


#1

Hi there,

i would really like to use omnioutliner. but its essential for me to work on my synolgy. omnifocus 2 is working great with webdav. when i try to set up omnipresence with the same webdav settings as omnifocus 2. but i get the following error:

We could not connect to your selected cloud location.

The network connection was lost.

im using a synology 214j (dsm 5.1) with webdav service enabled.


#2

I tried this on my own Synology, and the issue is that the WebDAV server is crashing during one of our conformance tests.

You should be able to see the error on your own Synology server by checking the log file /var/log/httpd/webdav-error_log. Mine says:

[Wed Mar 04 20:46:32 2015] [notice] child pid 21860 exit signal Segmentation fault (11), possible coredump in /etc/httpd

I’m not sure why it’s crashing, but it seems like that’s something Synology should address.


#3

thanks kcase. yeah got the same error :(

thanks for the heads up.


#4

Status update: Synology support has fixed this for at least one customer with the DSM 5.2 beta, and it sounds like that fix will be available to everyone before too much longer (presumably when 5.2 goes final).


#5

That sounds great. Thank you!


#6

I’ve tested 5.2 Beta and it’s still not working for me. On iPhone. I get this error:

… returned “method not allowed” (405) in response to request to “MKCOL/omni/omniDAV-Conformance-Tsts-ndp4nVevOKB/fortestReplacedCollectionUpdatesModificationDate: /parent”.


#7

Update on this. Official release of 5.2 has allowed me to set up Omnipresence on my Mac and iPhone … but not on my iPad. Both Graffle and Outliner fail with the same message as above. Not a problem on my iPhone with the same applications.


#8

If you haven’t already, please verify that you are running the same versions of iOS 8, as well as the same application versions, on each device, and then email omniplan-ios@omnigroup.com. If everything else is the same, then we don’t want the iPhone and iPad acting differently!


#9

This is definitely not fixed in the latest DSM update. I get this error:

Method Not Allowed
The requested method DELETE is not allowed for the URL /OmniDAV-Conformance-Tests-htRiNb2e5pO/.


#10

Like @scoobs it’s not working for me on the latest version of DSM (DSM 5.2-5592 Update 3) and OmniPresence 1.4 on OSX. I get the message:

The requested method DELETE is not allowed for the URL /OmniDAV-Conformance-Tests-mp1e3FMEpgX/


#11

That sounds like a configuration issue (OmniPresence is trying to perform a delete operation on the temporary folder it used during conformance testing, but the server isn’t letting it), whereas the original issue was that the server would crash in the middle of the conformance tests.

So it sounds like this is definitely better, we just need to figure out what’s wrong with the configuration which is preventing the delete operation.


#12

I just tried reproducing this myself, and the solution turns out to be quite simple! When you enter the location for your synology server, you just need to include “/home” in the URL, like so:

https://my-synology-server.private:5006/home

Without /home, you’re trying to write to the root namespace of the DAV server and it won’t allow you to do that. But with /home, you’re writing to your home directory on the Synology server which works just fine in DSM 5.2.

Hope this helps!


#15

That sounds great. Thank you so much!


#16

Just to add to this, the /home needs to correspond to a Synology shared folder called home. A home folder doesn’t exist by default (at least not on my Synology), you’ll need to create it and you can call it whatever you’d like. I called mine webdav to make it clear what it’s contents were.