WebDAV sync stopped working

Been syncing just fine. Installed the Apple Security Update 2016-003 and now I can’t sync at all. I keep getting this error:

The **** server returned “method not allowed” (405) in response to a request to “PROPFIND /DAV/OmniFocus.ofocus”.

I’ve verified that the permissions are set and the DAV folder is properly shared.

Does anyone have any other suggestions?

Finally in an attempt to just try everything I added SMB and AFP access to the original WebDAV access on the DAV folder and suddenly it’s all working again. No time right now to see why they are needed but it certainly changed from before the security update.

Just started not syncing again, same error message. previous fix doesn’t this time.

You might try connecting to your WebDAV folder via the finder. Can you copy items to/from your WebDAV folder using the same URL in your OmniFocus Sync preferences? If not, likely a permissions issue, network problem, or an issue with the URL used in your preferences.

If you can reach and copy to the WebDAV folder from the Finder but not OmniFocus, you may want to contact support who can help you track down the cause and get you syncing again. Sometimes a console log can help if you go to https://support.omnigroup.com/console-osx/ and also an a Sync log may help them. From the OmniFocus menu, pick Preferences, Synchronization, then Click on Show Sync Details, Log tab, and Copy the log. Often that can help us along with the console to know when Syncing last worked and give a specific error to go from.



I guess I’m not understanding what you mean, I can copy, move add or delete files in the WebDAV folder from finder with no problems. The DAV folder is on the same machine as the Omnifocus instance I am trying to sync.

However, I did create and send a log file and I have contacted support but they are only just answering messages sent before 30 Sept now according to the message I got back so not likely to get a quick answer from them.

Can you copy items to/from your WebDAV folder using the same URL in your OmniFocus Sync preferences?

I guess I’m not understanding what you mean, I can copy, move add or delete files in the WebDAV folder from finder with no problems. The DAV folder is on the same machine as the Omnifocus instance I am trying to sync.

However, I did create and send a log file and I have contacted support but they are only just answering messages sent before 30 Sept now according to the message I got back so not likely to get a quick answer from them.

Since you can’t sync, if it is stopping your work, you may get through quicker if calling from a phone is possible. +1 206-523-4152 or 800-315-OMNI (10a-5p PDT M-F) is the info. Syncing to WebDAV is complicated with many moving parts, so an interactive conversation might help if it is possible.

Support humans have been pretty swamped. With iOS 10 coming out and Sierra, plus many people getting new iPhones, they have their hands full. I’m sorry about the delay. Many of us are helping out some as possible. I apologize for any suggestions that are at the wrong level of detail. If you do try some of these ideas, let support know what you tried and what the result was. I hope that at least we can narrow down the problem some with these suggestions.

What I meant to suggest as a test by reaching the server folder in Finder is choose from the Menu Go>Connect to Server, then paste the URL from your OmniFocus Synchronization prefs directly in to that dialog, are you able to connect? Is there a file named OmniFocus.ofocus inside? If so, we know that the path OmniFocus has to navigate is a good valid path to the desired folder. If you get an error from this test, the problem is with the WebDAV server configuration or the path in your preferences is no longer valid/reachable.

I have a few ideas you can try to isolate the cause of the issue if you want to.

  1. In your preferences, under Synchronization, Show Sync Details, go to the Encryption panel. Is Encryption on? What does the 2nd icon down say? Are your passwords linked or distinct? Are you missing the Encryption panel? Please update your OmniFocus version and try syncing again.

  2. Check that you have set a user name and password longer than 4 characters each. Is it WebDAVNav server you are using? If so, try to use HTTPS and make sure your password & username are at least 4 characters long if you are using encryption. If this isn’t all the case, go back in to your WebDAVNav server settings, check “Use Https”, under Authentication, change password/username to something at least 4 characters each, stop and restart the server. If you are using WebDAVNavServer, go to Settings from WebDAVNavServer and there are 2 paths there. One will be a number using your IP, the other will be something like “https://Names-MacBook-Pro-1.local:8080/” Use the second one as your path instead of the first one for your OmniFocus Synchronization preferences as many Internet providers do not give you one consistent IP address that you can rely on consistently. Also, does your folder name have spaces in it? Try changing it to one with no spaces, “WebDAV” or “DAV” or something quite simple is best. If you changed the folder name, restart the server, update the OmniFocus preferences and try syncing again.

  3. Do you have any file cleaner type software running? The Mac cleaner software is known to mess with cache files and generally cause major headaches for syncing as it is deleting files that are still needed in some cases, but because they are only used when you sync, they get mistakenly identified as temporary files. If you’ve run some type of cleaner program, the best option is to set up Sync again from scratch so that no cache is needed, and then do not run that program again as it isn’t safe for syncing. Please reply again if this might be a factor. Ignore if there is no cleaner software.


Yes I can get to and see the OmniFocus.ofocus file from finder
Yes I have encryption on
Yes the passwords are linked. I just reset them to be sure
Yes the password is longer than 4 characters
No I am using Apple’s Server App not the WebDAVNav app and I used the Omnifocus info from here to get it set up https://support.omnigroup.com/omnifocus-sync-osx-server/
Folder name is DAV no spaces
No file cleaner software is running on my mac

Again, things were working but have stopped. I’ve tried disabling file sharing restarting the entire mac including server app and then re-enabling it and re starting. I’ve also tried the changing of access per earlier messages with no effect.

Right now I am entering in all changes on either my MacBook or iPhone as that is still working to sync

Those are good signs, especially with you being able to sync from other devices that your setup is correct and your data itself isn’t a problem. If at any time you would rather call support, please do so and only try what you are comfortable attempting.

Questions and Details
Can you check on the Mac that is not syncing which OmniFocus version is installed? OmniFocus menu, About OmniFocus, and the exact number should show there. If the version is 2.7.1, that is up to date and has the keychain fix for encryption that solves an issue like this with some WebDAV servers. If you have 2.7.1 just ignore this, otherwise update OmniFocus. Did this begin after you updated OmniFocus? Or has it synced on this version with success?

On your MacBook that is syncing, go to OmniFocus menu, Preferences, Synchronization and click Show Sync Details. Click Encryption. If it says Encryption is active, does it say the passwords are linked or distinct? Or that Encryption isn’t active? I ask because the suggestions would be different depending on these settings. If you’d rather not share that in public it is good information for support to know. If Encryption is disabled, that detail is good to know as well.

Since it was syncing before, what changed around when it failed? If you go to the Mac where syncing is failing, under the OmniFocus menu, check Preference, Synchronization, Show Sync Details>Log. Is there anything that happened right before sync failed in that log? It may help support to have a copy of that log, especially right before and after it stopped being able to sync. The reasons for the Sync can be useful in trying to determine why it stopped working.

What does the console say? On the non-syncing Mac, type Console into Spotlight, press return. Attempt to sync. What is printed in the Console? There may be a more detailed error that will help us determine the problem. If it matches the error you’ve already shared, that is also good to know.

Is there a firewall or any anti-virus software running on this Mac that isn’t syncing? If so, try adding an exception in that software temporarily for OmniFocus and attempt to sync again.

Which version of MacOS (or macOS as the case may be) are you using? You said you recently got a security update previously. Any changes that could be relevant here? I will try the same update here to see if I can reproduce the issue if we aren’t able to resolve this now.

Troubleshooting Steps

  1. You could try going to the Server WebDAV folder to the OmniFocus.ofocus file, rename it temporarily or delete it if you have another backup, then Sync from one of the syncing devices that are working. See if this allows you to sync from the Mac.

  2. If still unable to sync on that same Mac as before, type Keychain Access into your Mac Spotlight and press Return. Find just the key for your WebDAV account on the Mac and delete it. Try to Sync, which should ask you for your password. Enter the password and see if you are able to sync. If you are not able to sync, try step 3.

  3. With OmniFocus on Mac launched, Control click on the icon at the top of the window, Click the OmniFocus folder from the menu that appears there, and rename OmniFocus.ofocus to “Backup.ofocus”. Now quit and relaunch OmniFocus where you’ll set up syncing again. You’ll enter your WebDAV info to point OmniFocus to the right place and set up the preference again. Now try to sync. If still unable to sync try step 4.

  4. Make a new folder on your Server and try to sync to the empty folder from just the Mac that can’t sync. I’m only suggesting this because the folder permissions changing helped before. If the new folder gets syncing to work, go to the MacBook that is syncing, enter in that path in preferences but do not sync, then replace server database from the file menu to get your newest info. If this works, there is a problem with either the folder permissions or something about the file inside that is the cause.

  5. If encryption is on and this started after you migrated your database to the new format, you may want to try to restore a pre-migration backup on the device you first migrated on. Before you try this please export an OmniFocus Backup locally to be sure none of your data is lost. After syncing is working, open up this backup and use copy/paste to bring in anything added since the backup. Under the File Menu, go to Backups on one of the syncing devices and search for the backup named “Before Migrating Database” in the title. Restore that backup. If you do this, you will be notified on each device when you sync next that Encryption isn’t used. If this works to get all devices syncing, make sure that you are on version 2.7.1 and sync all devices before migrating forward. If the pre-Migration database can sync, there may be an issue with Encryption on this device. If this suggestions works I can send you some further options on how to proceed.

  6. On the Mac that can’t sync: Create a new user account and Install OmniFocus to it. If you can sync from a new user account, but not your account, something may be wrong in your User Settings on the Mac or something unique about that user profile causing the issue.

I hope at least one idea can help you. I know the list is really long, but it is everything I would try if this were my machine not syncing. Please skip anything you are uncomfortable with and rely on support if you’d prefer a more specific suggestion. If one of these ideas gets you syncing again, please let us know which step so that someone else in the same situation can try that step.


Running OF 2.7.1 (v109.13 r270584)
This version was successfully syncing from all devices before. Only changes is that one device, the MacBook was upgraded to El Capitan. Mac that is not syncing is still on Yosemite.
Syncing version yes encryption on and yes passwords linked
As far as I can tell nothing was changed when it failed. I have deliberately not upgraded or made any changes to software on that machine until I wring out all issues with El Capitan on the portable. I’m in the middle of software development with some changes I need to deliver by this Sunday and did not want to muck with a working existing system. I typically delay upgrading to major version of operating systems until the next is out there due to my own internal SW development cycles.
The log is empty. Not sure entirely why. Console log was captured and saved, here are a few key excerpts, I don’t really want to post the entire thing here:
10/4/16 8:25:22.981 PM OmniFocus[8280] Presenting application modal error for window Window: {
Then lots of additional info followed by
10/4/16 8:25:41.656 PM OmniFocus[8280] Sync terminated with error:
No antivirus
Server.app is running the firewall
non-syncing mac is on 10.10.5
syncing mac is on 10.11.6
The security update was a while ago but it was syncing after that so in retrospect I don’t think that’s the issue.

I’l tackle some of the troubleshooting stuff later, got to go feed sheep right now.

OK Latest update. I got a message from support that saw this in the log file.

"There’s one thing that stuck out for me when looking at your logs. If you look at the path that OmniFocus is using to talk to your server, there’s a period right after local.


I don’t usually see that, and it wasn’t in the path to your server in your previous correspondence"

Based on that I went into the preferences to see what was there and there was no period. So I couldn’t delete it as it didn’t show up at all.

However in case something was just amuck I first set to don’t sync, shut down OF and Rebooted the mac
Bring up OF and set the sync to advancedWebDAV and retyped the address in. It still looks the same but now the system is again syncing from this mac.

I’ve now also verified that I can still sync from my MacBook, iPhone and iPad.

Awesome news! I hope that you and your sheep are doing great today.

With a message as general as not being able to connect, it can take some time to isolate the issue. Our support humans have great understanding of the sync logs, so I’m glad they found you a more specific step that resolved the problem.

I appreciate you writing back and letting us know what fixed the issue.


I had a similar error twice now. It was gone after I unchecked and checked again the first 4 boxes unter “Access” (iOS, SMB, AFP, WebDAV) in the editing menu of my “DAV” folder in the File Sharing service of my local Apple Server 5.2. (The method worked at least the second time the error occurred)

My error read:

The **** server returned “forbidden” (403) in response to a request to “PROPFIND /DAV/OmniFocus.ofocus”.

Sadly after upgrading my main mac to El Capitan sync is again dead. I’ve tried all the things that worked to fix it in the past, but no go. Am contacting support now.

I believe I have the fix, or at least I’ve got it working again.

The issue is related to the self signed certificate for secure access.

Fix is
first delete the certificate in server.app
Create a new one and self sign it.

Go into OF and set up no sync
go into OF set up sync with WebDAV
When you get the untrusted certificate message select show certificate
in the drop down area click the arrow to the left of the trust in the when using this certificate are select the drop down for always trust
click continue

DO NOT use the Always trust checkbox at the top and DO NOT just trust once.

And now it’s dead again, no changes made at all to anything, stopped sometime last night

no sync working on iOS devices or from other machines or even from my main machine to the sync location.

All previous fixes including trying to create a new certificate did not work.

This is getting REALLY old.

Sorry to hear that the connectivity saga continues. Based on the notes from last time, I’d try to isolate where the problem is coming from first to identify if the server itself is having trouble, or just OmniFocus.

To check the server, in the Finder, choose Go, Connect to Server, and enter the same exact path as you have in your OmniFocus Sync preferences with the same username/password. Try to copy a file to and from that window. You want to use Connect to Server and not the Finder because they aren’t the same path. If you can not copy to and from the server directory you are using in OmniFocus, there is a problem with your WebDAV server beyond OmniFocus. If this test fails, you may want to ask in a more general Apple forum as it could be a known WebDAV issue.

If you can copy files to and from your WebDAV server, there still may be a problem on the server side or between the server and OmniFocus, but if you include any messages in the Console (Search for Console in Spotlight, Try to sync, Copy messages that appear), as well as your WebDAV Server Log, that may help support assist you in getting OmniFocus working again. Send to omnifocus@omnigroup.com if you can read/write/edit files in that directory but still can’t connect to OmniFocus.

If you want to explore options other than administering your own WebDAV server, there are some suggestions we could make that might be worth trying to see if they are a better solution at this time. The other options are using the free WebDAVNavServer https://support.omnigroup.com/omnifocus-sync-webdavnav/ and now that we have encryption, some people are able to use OmniSyncServer which is also free.

I hope that your sheep are doing well! I’m sorry that this trouble continues to interfere. Hopefully some of these ideas can isolate the cause a bit more and at least give you some alternates to consider as well.


I can move files to the server.

Nothing useful in the log files that I saw but I already sent a message to support.

Encryption or not I cannot and will not use the Omnifocus Sync server. I am required to keep everythign in-house.

WebDavNav isn’t an option because some other WedDAV stuff I am running that is working requires the Apple server not something else. I can’t really run 2 servers on my system.

Please contact support when the time works for you in whichever way is best. The problem that you are encountering isn’t typical. You’ve done a great job trying the troubleshooting steps to resolve the issue at this point, but you may need more specific and focused advice to diagnose the problem. Contact details appear at the top at https://support.omnigroup.com/omnifocus.