What happens if I’m ahead of schedule in OmniPlan

'm running a few days ahead of schedule in my OmniPlan project, but even though I’ve marked some events as 100% complete, they still get scheduled as future tasks when I level my plan and my project’s end date is never updated.

What can I do to get my project plan to reflect being ahead of schedule? It seems to have support for falling behind schedule, so there must be a good way to handle this.

@FrancisRamirez OmniPlan should certainly be able to handle the scenario you described! Hopefully you were able to sort this issue out already, but if not please send our Support team an email - omniplan@omnigroup.com. Thanks!

I have the same question and it sounds quite basic so was hoping to find the solution here (vs having to email support). This is not in the documentation. If you can re-schedule incomplete tasks then completed tasks should also be able to push ‘back’ in the past so they don’t affect future dates?

@sureshbp I’m afraid I don’t quite understand your question! Are you having trouble marking tasks complete? Task completion can be updated in the Inspector or by dragging the completion slider in the Gantt chart. Alternatively, you can mark all scheduled tasks as complete up to the current editing date via the “Catch Up” options - more info on this feature if available in our documentation here.

If OmniPlan’s task completion functionality is not working the way you expect it to, our Support team is your best resource for resolving this issue. They can be reached by email or phone from 10-5PM Pacific. omniplan@omnigroup.com or 800-315-6664

Question was same as what previous user asked. Here is the scenario. You put in tasks with effort estimates and resources and Omniplan schedules them into the future. Let’s say some of those tasks have dependencies to each other and the dependent tasks are assigned to different people. Now let’s say first resource is very efficient and gets done with the tasks well ahead of schedule. I will go ahead and mark them 100% complete in omniplan. Now when I re-level, what I expect to see is that the complete ones are not causing the dependent ones to still be scheduled far into the future. But that is not what I see. The complete ones (in dark blue) stay where they are in the original schedule and cause their dependent ones to push out. That doesn’t make sense.
Just like when re-leveling Omniplan will re-schedule incomplete tasks into the future, it also needs to put ‘behind’ complete tasks so they don’t affect anything in future. This seems kind of basic and fundamental and I am surprised there have not been more questions on this. Right now the only way 100% complete tasks seem to affect the schedule going forward is that omniplan can assign the same resource a different task during the same period in the schedule since total usage for that resource is still only 100%. That is not enough. Hope that is clearer? If not please give me a number I can call so I can talk to a tech directly. I work at Apple and we are trying to evaluate the tool vs others and this ‘bug’ or lack of feature is a deal-breaker for me.

Hey guys, I am also in a trial version considering between a few project management software. I got a solution for this problem. It is not straight-forward, but a work-around…

Option 1. Making changes to the existing project
Marking the task “effort” or “duration time” to the actual time spent. This should adjust the timeline accordingly. A proper reporting on the time/resource management would also be generated. By doing this method, some workers could be highly rewarded by their productivity and production mangers would understand/value some workers :)

Option 2. Adding an old project
Step1. Expand the whole project (to view all the sub-tasks) and highlight all tasks.
Step2. Click on the Inspector -> Task -> Schedule and change the start date.

Considering you have done your dependencies correctly, all completed tasks would automatically fall back on the previous working-day/days. If you are way-ahead of schedule you should consider adding more than one working day, so that all completed tasks no longer show up on your timeline. This would also push the project timeline end date ahead :)

2 Likes

I had the same problem, a future task in the plan has been completed, but when I marked it as complete, it still occupies the resource’s usage time in the future