What to input in "Account / Google" field?


#1

Hi, I would like to sync my OmniPlan 3 content with Google Calendar.
(I’m using Google Apps.)

In the “Account” tab in preference, which should I choose “Google” or “CalDAV”?

When I selected “Google” and input my GoogleApps email account and password,
“unauthorized” was displayed when I pushed test.
(I’m sure that my email/password is correct. I’m no using 2 phase auth in my Google Apps)

What should I input for username and password?
Is this feature currently working?


#2

@slash5234 This feature does still work, but Google now considers OmniPlan sync to be “less secure” and blocks access by default because we don’t offer two-factor authentication. However, if you wanted to allow OmniPlan access to Google, you should be able to do so by turning on access from this page in your Google Settings: https://www.google.com/settings/security/lesssecureapps

We have an open bug report for this issue in our development database - I’ll attach your comments so that the rest of the team is aware you’ve encountered it as well!


#4

Hi
I have been trying to sync the project with my google calendar. Less secure apps setting has been turned on. When I try to log-in from preferences and hit to “Test” I get “unauthorized” error.

Is there any workaround on this? or any solution to sync with Google Calendars?
Thanks

Berk


#5

@Berk Our Support team would be happy to look into this with you! Could you send them an email or give them a call? omniplan@omnigroup.com or (800) 315-6664

Thanks!


#6

@ains
Thanks, will do that right way…


#7

If you were unable to figure this out, it could have to do with creating an app password (if you have 2-factor authentication on). The same issue happens with MS Outlook for Mac. https://security.google.com/settings/security/apppasswords