When clipping, what does a "Error compiling handler script” message mean?

I keep getting the following error

The sript handler failed
Error compiling handler script for <ScriptHandler:0x608000113170 com.omnigroup.OmniFocus.ScriptHandler.Mail_with_MailTags NSBundle </Applications/OmniFocus.app/Contents/PlugIns/BuiltInClippingHandlers.plugin> (not yet loaded)>: Expected end of line, etc. but found variable name

Did you happen to modify the script at all from version 1?

To be honest, i can’t remember.

I have been thinkering with at few scripts but it must be at least a year since i settled on the setup that I have today. Is there a way to get a fresh copy of the script?

I’ve seen this recently in the Mail and Mail with MailTags handlers. The Mail handler was fixed in r206215, but I missed fixing the MailTags variant until r206352.

(The issue was that we were using terminology from the wrong app when trying to insert text into the note of the new OmniFocus inbox item.)

I have been having this issue as well, despite not having toyed at all with any scripts; it happens to me no matter where I try to clip from (Safari, Airmail, Preview, PDF Reader X, etc.). I emailed support with the news and haven’t heard anything.

The outcome, by the way, is that the OF app icon bounces in my dock, and the alert popup sticks around until I dismiss it. Then I find my new Inbox item with the selected text as the note, formatted and everything, but no task name of any kind.

I’d love it if the option from OF1 to clip either into the Inbox or into the Quick Entry window could be restored — it was an excellent way to save snippets from academic articles into their appropriate homes to be able to select the latter option.

Thanks, Ken & Co.!

1 Like

I’m having the same exact problem Just installed Omni Focus 2 for the first time. Never had Omni Focus 1.

You have described my experience exactly.

I too have this problem and it’s a blocker (I may go back to OF1).

This is the full error, I get it when clipping in Mac Mail Version 7.2 (1874)

Error compiling handler script for <ScriptHandler:0x61000010e6a0 com.omnigroup.OmniFocus.ScriptHandler.Mail NSBundle </Applications/OmniFocus.app/Contents/PlugIns/BuiltInClippingHandlers.plugin> (not yet loaded)>: Can’t get note of MyTask. Access not allowed.

Once I click “ok” in OF on this modal, the Quick Entry box finishes rendering the message (although it doesn’t contain a message id URL back to the mail message).

What’s the fix for this?


@yanowitz Are you using OmniFocus Pro or Standard?

@lizard I’ve tried it both ways.

I have a similar but different error. My error is for both Chrome and Safari clippings:

Error compiling handler script for <ScriptHandler:0x7fca53f40f60 com.omnigroup.OmniFocus.ScriptHandler.Safari NSBundle </Applications/OmniFocus.app/Contents/PlugIns/BuiltInClippingHandlers.plugin> (not yet loaded)>: Expected “,” but found “text”.

If I open up the scripts inside of AppleScript Editor, I see the same error when I click Compile. The odd thing is that after I receive that error, the popup is filled in with my selected text, so it appears to function despite getting prompted with the error.

I don’t have OmniFocus 1, but I had run it in the past. I’m a standard user.

I was having this same clipping issue and realized I didn’t have the PRO version of V2. I just upgraded and it works fine now.

I ran the script directly via the Applescript Editor - the error I am getting is:

Syntax Error
Can’t get note of MyTask. Access not allowed.

this is happening on this line: tell note of MyTask (does the AS editor really not have line numbers?)

line 31

Any guidance here would be great. There seems to be in consistencies with the solutions to the clip-o-tron

Exactly the same problem here…

But it shouldn’t be the case that a PRO license is required to use the Clippings function, which has always been standard and doesn’t require the user to write or import any scripts — right? I just updated my license to OmniFocus 2 (Standard) and I still am having this issue.

Scratch that. I just uninstalled the ‘second beta’ version I’d been running (with my license attached), and re-downloaded OF2 from the website. The clippings work perfectly now.

I’ve got this annoying problem too.
I’ve used the OF1 (try period) before buying the new OF2.

I’ve try to uninstall everything… but when i reinstall OF2, it magically founds all my settings.

I’dont know if it is related, but now, all the “email send to omnifocus inbox” looses the link back to the original email.

This was one of the reason i bought OF2…

Is there a way to do a fresh, clean install from scratch ? => OK, i’ve got to parse all item in my Library to find omnifocus entry, but clean install does not change anything

This is a real nightmare, no link to original email message

I had the same “Error compiling handler script” error. I installed v2 but I remembered I chose to keep both versions. I uninstalled both versions and reinstalled v2. My information is synced to the cloud.

Everything works now. Make sure you use an uninstaller that gets rid of all application support files. I use the App Sweep utility in Hazel.

This worked for me. After uninstalling (with Hazel) I also did “secure empty trash”. Thanks!

p.s. but clipping from Firefox/Safari is still not working, grrrr

p.p.s. and now, one day later, unfortunately all the original error messages are back and clipping doesn’t work at all. Please Omnigroup give us an update to solve this problem.

1 Like

After initially working after reinstalling, the error message returned after setting a clippings shortcut. Yes, please Omnigroup, fix this.

1 Like

Back to having my problems again — which is odd because I didn’t believe I’d updated. Now I tried an uninstall and clean reinstall, and still can’t keep the error message from coming back.