Creating gap between arrow-head and object

Is there some trick to create a gap between an end of the arrow and it’s target?
I’d like to create a gap between the tip of brace and arrow

I tried removing magnets from brace, and dragging the tip of arrow away, but the arrow wildly goes “all over the place” when I drag, so I can’t position it just right

Here’s graffle file

Hi! There is no convenient trick or option for creating a gap between the end of an arrow/line and the shape it is connecting to. If this is an option you’d like to see, please send us an email so support team can get your thoughts recorded in our development database.

That said, with some effort, this is possible to do if you have the Pro version of OmniGraffle. With the Pro version you can select these lines, and set them so they do not connect to other objects (this option is found in the Connections Inspector). This will allow you to then move the end points of these lines so they aren’t directly touching the braces you have them connecting to. This can still be a bit challenging to get things to line up just right. It helps to use a grid, and have Arrange > Grid > Snap to Grid enabled.

To help demonstrate this, I made these changes to your document, and uploaded a copy with you can download here.

1 Like

Thanks, the Connections Inspector did the trick for me. BTW, one slightly annoying thing I noticed that even with snapping, the default arrow heads (triangle) are not perfectly aligned to grid. The other arrow head types are perfectly aligned however (square, circle)

Another trick is to give the target shape an invisible border, so that the arrows can connect to that rather than to the ostensible target.

You can write a script to convert a selected vanilla target/source shape to a group composed of a the original (visible) shape and a slightly larger invisible version of itself, equipped with the magnet pattern that you need.

(Analogous to ‘lifting’ a raw value into a monad :-)

That is because the line (the endpoint or whatever you have selected, that you are trying to move) is immediately above or very close to, another shape, and that shape is enabled to have lines connected to them. Turn that off on those shape, or lock them, temporarily. Then the lines (arrows, whatever ends the lines have) will not magically move, wildly or otherwise. OG6 is pretty bad, but it is not that bad. You can’t expect lines not auto-connect when you are hovering over a shape that has auto-connect set.

You can, once you set the object behind it correctly, or when there are no objects behind it. It is very precise.

Further, your ruler is not set up reasonably. You are working at a microscopic level, while drawing macroscopic shapes. Try setting it to 0.5 inch (major) and 5 or 10 (minor).

Separately, I suggest you spend less time getting the drawing perfect, and more time getting the message across, and clearly. Eg. use a Standard, such that the info is communicated fully and accurately, rather than creating a syntax yourself, and therefor having to get the diagrammatic notions of that new syntax perfect. Those queue elements are really simple elements, so make them up from boxes, and rows, and get rid of the braces and the queue-as-background. Ie. the queue entries vs the content of the queue entry, are not at all clear. And then connect the arrows to boxes (either queue entries at left or right, or entry-content at above or below), using the default magnets.

That is a very good concept, one I use regularly. But it is worthy in situations where the objects are complex (grouped; layered; etc). This scenario has very simple objects, I would think it is over-kill.

Always place the invisible shape behind the base shape. That allows you to access both shapes with ease.

Turn off the magnets on the base shape. That will prevent the arrow-heads “jumping around wildly”.

Well, at least in OG5, they align (snap to grid) perfectly. OG6 is unpredictable.

Try: Select the line, and AlignToGrid.

Also, it may be made worse by your 72pt major 6 minor ruler set up.